Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80211 - acpi not enabled on Dell Inspiron 8000
Summary: acpi not enabled on Dell Inspiron 8000
Keywords:
Status: CLOSED DUPLICATE of bug 82123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-22 10:11 UTC by Alexandre Oliva
Modified: 2013-07-03 02:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:30 UTC


Attachments (Terms of Use)
Output of dmidecode on laptop (deleted)
2002-12-22 20:47 UTC, Alexandre Oliva
no flags Details

Description Alexandre Oliva 2002-12-22 10:11:23 UTC
/proc/acpi does not exist on my ssytem, and trying to modprobe some of the
drivers inside /lib/modules/2.4.20-2.2/kernel/acpi (e.g., ospm_battery) may even
cause the kernel to print an oops message.  Also, apm says apm support is
disabled in the kernel, so...

I can no longer suspend, hybernate or even blank the screen of the laptop.  The
Fn key sequences that I used to use for these operations no longer work, but
other key sequences still work, so I suppose it may be related with the lack of
acpi/apm support in the kernel.  Is this assumption correct?

Comment 1 Arjan van de Ven 2002-12-22 11:25:02 UTC
please try acpi=off on the kernel commandline and attach dmidecode output to
this bug

Comment 2 Alexandre Oliva 2002-12-22 20:47:11 UTC
Created attachment 88857 [details]
Output of dmidecode on laptop

acpi=off ``fixes´´ it, indeed.	Thanks!

Comment 3 Thornton Prime 2002-12-28 17:05:19 UTC
Here is the oops generated when loading the acpi_battery module
(beta3/redhat-release-8.0.92-2 kernel-2.4.20-2.2):


ACPI: Battery socket found, battery absent
    ACPI-0189: *** Warning: Buffer created with zero length in AML
Unable to handle kernel NULL pointer dereference at virtual address 00000010
 printing eip:
c0188201
*pde = 00000000
Oops: 0002
ospm_battery ospm_button ospm_system ospm_busmgr nfs lockd sunrpc autofs ide-cd
cdrom ds yenta_socket pcmcia_core e100 iptable_filter ip_tables microcode ohci
CPU:    0
EIP:    0060:[<c0188201>]    Not tainted
EFLAGS: 00010246
 
EIP is at acpi_ds_execute_arguments [kernel] 0xd1 (2.4.20-2.2)
eax: 00000000   ebx: 00000000   ecx: c1afd400   edx: c8006ce0
esi: cfb21400   edi: c1addf60   ebp: c8006ce0   esp: c87d99b0
ds: 0068   es: 0068   ss: 0068
Process insmod (pid: 1305, stackpage=c87d9000)
Stack: cfb21400 00000001 00000000 00000000 00000000 00000000 00000000 00000001
       cb12b420 cb12b420 cfb211b4 00000000 c018838d c8006ce0 c8006ce0 00000000
       00000000 c8006ce0 c0193a99 cb12b420 c87d9a10 00000003 00000000 cfb211b4
Call Trace:   [<c018838d>] acpi_ds_get_buffer_arguments [kernel] 0x3d (0xc87d99e0))
[<c0193a99>] acpi_ex_resolve_node_to_value [kernel] 0xc9 (0xc87d99f8))
[<c0193b2a>] acpi_ex_resolve_to_value [kernel] 0x4a (0xc87d9a1c))
[<c0188d0c>] acpi_ds_resolve_operands [kernel] 0x2c (0xc87d9a30))
[<c0189399>] acpi_ds_exec_end_op [kernel] 0x139 (0xc87d9a48))
[<c0198ed3>] acpi_ps_parse_loop [kernel] 0x553 (0xc87d9a68))
[<c0185de4>] acpi_ut_release_mutex [kernel] 0x74 (0xc87d9a8c))
[<c0185de4>] acpi_ut_release_mutex [kernel] 0x74 (0xc87d9a94))
[<c0185fb7>] acpi_ut_delete_generic_state [kernel] 0x17 (0xc87d9aa4))
[<c01846b8>] acpi_ut_update_object_reference [kernel] 0xb8 (0xc87d9ab0))
[<c0185d45>] acpi_ut_acquire_mutex [kernel] 0x75 (0xc87d9ad0))
[<c01834f5>] acpi_ut_release_to_cache [kernel] 0x45 (0xc87d9ae8))
[<c0185de4>] acpi_ut_release_mutex [kernel] 0x74 (0xc87d9af8))
[<c0199548>] acpi_ps_parse_aml [kernel] 0x1f8 (0xc87d9b18))
[<c018a5b5>] acpi_ds_init_aml_walk [kernel] 0xc5 (0xc87d9b28))
[<c0199fbc>] acpi_psx_execute [kernel] 0x20c (0xc87d9b4c))
[<c8c9f104>] .rodata.str1.1 [ospm_battery] 0x0 (0xc87d9b80))
[<c0195968>] acpi_ns_execute_control_method [kernel] 0x58 (0xc87d9b84))
[<c01958eb>] acpi_ns_evaluate_by_handle [kernel] 0xab (0xc87d9b9c))
[<c0195741>] acpi_ns_evaluate_relative [kernel] 0xf1 (0xc87d9bb8))
[<c01846b8>] acpi_ut_update_object_reference [kernel] 0xb8 (0xc87d9be0))
[<c7f930e4>] .rodata.str1.1 [ospm_busmgr] 0x160 (0xc87d9c00))
[<c0184868>] acpi_ut_remove_reference [kernel] 0x38 (0xc87d9c04))
[<c8c9f104>] .rodata.str1.1 [ospm_battery] 0x0 (0xc87d9c10))
[<c0197458>] acpi_evaluate_object [kernel] 0x88 (0xc87d9c18))
[<c8c9f104>] .rodata.str1.1 [ospm_battery] 0x0 (0xc87d9c20))
[<c8c9f104>] .rodata.str1.1 [ospm_battery] 0x0 (0xc87d9c44))
[<c7f92ac8>] bm_evaluate_object_R2ecf6ce0 [ospm_busmgr] 0x68 (0xc87d9c48))
[<c8c9f104>] .rodata.str1.1 [ospm_battery] 0x0 (0xc87d9c50))
[<c8c9e0fd>] bt_get_info [ospm_battery] 0x8d (0xc87d9c6c))
[<c8c9f104>] .rodata.str1.1 [ospm_battery] 0x0 (0xc87d9c74))
[<c8c9e3d5>] bt_check_device [ospm_battery] 0x85 (0xc87d9cac))
[<c8c9e4c1>] bt_add_device [ospm_battery] 0xb1 (0xc87d9cd0))
[<c8c9e6a2>] bt_notify [ospm_battery] 0x42 (0xc87d9cf0))
[<c7f9142b>] bm_register_driver_R21b2101e [ospm_busmgr] 0x10b (0xc87d9d00))
[<c8c9e5bb>] bt_initialize [ospm_battery] 0x7b (0xc87d9ec4))
[<c8c9e660>] bt_notify [ospm_battery] 0x0 (0xc87d9ed4))
[<c8c9e6f0>] bt_request [ospm_battery] 0x0 (0xc87d9ed8))
[<c8c9f050>] init_module [ospm_battery] 0x50 (0xc87d9f0c))
[<c8c9f212>] .rodata.str1.1 [ospm_battery] 0x10e (0xc87d9f10))
[<c011d021>] sys_init_module [kernel] 0x4e1 (0xc87d9f1c))
[<c8c9e060>] bt_print [ospm_battery] 0x0 (0xc87d9f20))
[<c8c9f9d4>] .kmodtab [ospm_battery] 0x0 (0xc87d9f2c))
[<c8c9e060>] bt_print [ospm_battery] 0x0 (0xc87d9f58))
[<c01096ff>] system_call [kernel] 0x33 (0xc87d9fc0))
 
 
Code: 89 50 10 89 3c 24 e8 e4 1a 01 00 c7 04 24 37 00 00 00 e8 18


Comment 4 Jeff Garzik 2003-01-17 21:22:39 UTC

*** This bug has been marked as a duplicate of 82123 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:30 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.