Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80154 - 'neat' crashed, line 774, update_devicelist
Summary: 'neat' crashed, line 774, update_devicelist
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: internet-config
Version: 8.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
: 80153 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-20 19:55 UTC by bennie smith
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-21 22:16:14 UTC


Attachments (Terms of Use)

Description bennie smith 2002-12-20 19:55:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
(This might go in you netcfg category.  There was no category for 'neat', the
app that crashed.)
Red Hat 8.0, Bluecurve (based on Gnome I guess), KDE is NOT installed.
There is no elegant way to connect to the internet via PPP with a 56K modem, so
went to Internet Configuration Wizzard and set up ppp0.  Then opened System
Settings/Network.  Have to enter Root password.  Then select ppp0. Activate. 
Dialing happens. Connection made.  Then there's no way to tell how fast you
connect or to see the status of your connection.

Then after a few minutes, this happens:

Traceback (most recent call last):
  File "/usr/sbin/neat", line 774, in update_devicelist
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
63, in __init__
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
66, in load
OSError: Too many open files

The only things Open are neat, mozilla, and yahoo.  And 2 terminal sessions,
with nothing running in them.

The connection stays alive, but now there's no way to disconnect except to kill
the pppd process.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. System Settings/Network
2. Activate ppp0
3. Wait for error
    

Actual Results:  neat crashed as explained above.

Traceback (most recent call last):
  File "/usr/sbin/neat", line 774, in update_devicelist
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
63, in __init__
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
66, in load
OSError: Too many open files

Additional info:

Sure do miss rp3 with the little visual activity graph and an indication  of
download speed.

Comment 1 Ngo Than 2002-12-21 22:13:34 UTC
*** Bug 80153 has been marked as a duplicate of this bug. ***

Comment 2 Ngo Than 2002-12-21 22:16:14 UTC
It's a bug in rhpl package, which was fixed in rhpl-0.54-0.8.0.1. I hope it will
be released as errata soon.

In the meantime you could download it from ftp://people.redhat.com/than/8.0


Note You need to log in before you can comment on or make changes to this bug.