Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80139 - RFE: Postfix 2.0
Summary: RFE: Postfix 2.0
Keywords:
Status: CLOSED DUPLICATE of bug 72768
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postfix
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-20 16:35 UTC by Chris Ricker
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:29 UTC


Attachments (Terms of Use)
updated smtpd_multiline patch (deleted)
2003-01-10 00:44 UTC, Chris Ricker
no flags Details | Diff
diff for rawhide spec to make it work with postfix 2.0 (deleted)
2003-01-10 00:49 UTC, Chris Ricker
no flags Details | Diff

Description Chris Ricker 2002-12-20 16:35:23 UTC
Postfix 2.0 will ship momentarily

It's probably too late to make beta3, but it'd be really nice if postfix is
updated to this new release before 8.1

Features added include:

* relay transport
* retuning of mail queue structure -- performance increase for most sites
* better organization of virtual user tables (increased performance and ease of
administration)
* better logging
* per user transports -- much greater flexibility

Comment 1 Chris Ricker 2002-12-23 06:38:06 UTC
It has shipped now:

 ftp://ftp.porcupine.org/mirrors/postfix-release/official/postfix-2.0.0.tar.gz

Comment 2 Chris Ricker 2003-01-10 00:44:59 UTC
Created attachment 89275 [details]
updated smtpd_multiline patch

Updated replacement for the smtpd_multiline patch ; works w/ both Postfix 1.1x
and Postfix 2.0

Comment 3 Chris Ricker 2003-01-10 00:49:41 UTC
Created attachment 89276 [details]
diff for rawhide spec to make it work with postfix 2.0

Comment 4 Chris Ricker 2003-01-10 00:57:55 UTC
Attached are two patches, an updated smtpd_multiline.patch (drop-in replacement
for current postfix-smtpd_multiline_greeting.patch) and a diff against the spec
file for postfix-1.1.11-6. Drop in the replacement, apply the patch, fix the
misnamed file (Bug 78020; mv SOURCES/README-Postifx-SASL-RedHat.txt
 SOURCES/README-Postfix-SASL-RedHat.txt), drop in the new Postfix and
Postfix-TLS source, and it'll build.

Main changes to the spec are:

* removing the postfix-1.1.4-sasl2-patch, since postfix 2 can already compile
against SASL2 w/o patching
* cp'ing /etc/passwd into the chroot jail. Postfix 2, unlike Postfix 1, rejects
unknown local users by default, so it must access /etc/passwd....

Alternately, it might be better just to disable the "reject unknown users stuff"
in the default shipped by RH?  To do that, put

local_recipient_maps =

in main.cf (ie, empty value)....

Comment 5 Chris Ricker 2003-01-13 05:58:53 UTC
Postfix 2.0.1 came out today. It includes a proxymap daemon which simplifies
Postfix 2 spec file creation greatly (since proxymap can be used even w/
chroot'ed postfix to access /etc/passwd, which means /etc/passwd doesn't have to
be copied in the chroot jail)....

Comment 6 Bill Nottingham 2003-02-19 00:38:45 UTC

*** This bug has been marked as a duplicate of 72768 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:50:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.