Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80131 - Package can't be built from source-RPM in usual way
Summary: Package can't be built from source-RPM in usual way
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpmdb-redhat
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-20 10:38 UTC by Andrey
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-20 13:38:07 UTC


Attachments (Terms of Use)
patch for rpmdb-redhat.spec.in (deleted)
2002-12-20 10:41 UTC, Andrey
no flags Details | Diff

Description Andrey 2002-12-20 10:38:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I tried to built this package from source-rpm
(rpmdb-redhat-8.0-0.20020910.src.rpm) but all my attempts were unsuccesfull.
Building craches at the %prep stage.
I found in spec-file the following:
...
#%dontdefine    rpmdbname               redhat
#%dontdefine    rpmdbversion            6.1
#%dontdefine    rpmdbversion               /mnt/somewhere
...
%prep
[ -d %{rpmdbtree} ] || {
    echo "This specfile needs access to %{rpmdbtree}/%{_arch}/Redhat/RPMS"
    exit 1
}
...
May be it will be better to define (for example) rpmdbname as 'redhat',
rpmdbversion as '8.0', rpmdbversion as '%{_tmppath}/rpmdbtree'. And then create
'%{rpmdbtree}/%{_arch}/Redhat/RPMS' directory needed for build.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -i rpmdb-redhat-8.0-0.20020910.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpmbuild -bb rpmdb-redhat.spec.in


Actual Results:  Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.46149
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ '[' -d '%{rpmdbtree}' ']'
+ echo 'This specfile needs access to %{rpmdbtree}/i386/Redhat/RPMS'
This specfile needs access to %{rpmdbtree}/i386/Redhat/RPMS
+ exit 1
error: Bad exit status from /var/tmp/rpm-tmp.46149 (%prep)

Expected Results:  Binary rpm should be built.


Additional info:

Comment 1 Andrey 2002-12-20 10:41:14 UTC
Created attachment 88833 [details]
patch for rpmdb-redhat.spec.in

apply this patch from WORK_DIR (not from SPEC)

Comment 2 Tim Powers 2002-12-20 13:38:07 UTC
That's because it's not built in the usual way :) 

The package is generated as part of the compose process, and not like any of the
other packages in the distro (aside from the comps package, which has to be
built in a special way as well). 

Tim


Note You need to log in before you can comment on or make changes to this bug.