Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80127 - odbc mysql problem - undefined symbol
Summary: odbc mysql problem - undefined symbol
Keywords:
Status: CLOSED DUPLICATE of bug 77635
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: MyODBC
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: Fernando Nasser
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-20 09:55 UTC by carlo beccaria
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:28 UTC


Attachments (Terms of Use)

Description carlo beccaria 2002-12-20 09:55:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
you will see error messages like 
relocation error: /usr/lib/libmyodbc.so undefined symbol: init_dynamic_array

redhat-release: Red Hat Linux release 8.0 (Psyche)

solution:
with rpm from mysql.com , all works fine
(MyODBC-2.50.39-1.i386.rpm,MySQL-*-3.23.54a-1.i386)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install mysql*-rpm ,unixodbc and My-ODBC(redhat8.0)
2.configure odbcinst.ini/odbc.ini
3.try isql --> help

configuration
------------------
$ cat /etc/odbc.ini 
[test]
Description     = database di test di mysql
Driver          = MySQL

cat /etc/odbc.ini
# From the MyODBC package
[MySQL]
Description     = ODBC for MySQL
Driver          = /usr/lib/libmyodbc.so
FileUsage       = 1

Actual Results:  relocation error: /usr/lib/libmyodbc.so
undefined symbol: init_dynamic_array


Additional info:

MyODBC-2.50.39-7.i386.rpm
unixODBC-2.2.2-3.i386.rpm
mysql-3.23.52-3.i386.rpm
mysql-server-3.23.52-3.i386.rpm
mysql-devel-3.23.52-3.i386.rpm

(RH8.0 standard packages)

Comment 1 Fernando Nasser 2002-12-20 16:50:32 UTC
The Red Hat Database is a product based on PostgreSQL.
We know nothing about MySQL.  I am changing the product to
Red Hat Linux, and component to mysql.

Comment 2 Martin Norback 2003-01-10 14:37:31 UTC
This is a duplicate of bug 77635

Comment 3 Patrick Macdonald 2003-02-13 17:15:56 UTC
This is a duplicate of bug 77635

*** This bug has been marked as a duplicate of 77635 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:28 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.