Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80126 - SRPMS: installation error due to missing files
Summary: SRPMS: installation error due to missing files
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xdelta
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-20 09:48 UTC by Sysoltsev Slawa
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-21 12:45:19 UTC


Attachments (Terms of Use)
Patch which removes need for xdelta.txt from .spec file (deleted)
2002-12-20 09:50 UTC, Sysoltsev Slawa
no flags Details | Diff

Description Sysoltsev Slawa 2002-12-20 09:48:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
building & installing xdelta from sources I've got such error:

Executing(%doc): /bin/sh -
e /netbatch/TC11631/rh80_ia32_O/default/WORK_DIR/tmp/rpm-tmp.69093
+ umask 022
+ cd /netbatch/TC11631/rh80_ia32_O/default/WORK_DIR/BUILD
+ cd xdelta-1.1.3
+ DOCDIR=/netbatch/TC11631/rh80_ia32_O/default/WORK_DIR/tmp/xdelta-
root/usr/share/doc/xdelta-1.1.3
+ export DOCDIR
+ rm -rf /netbatch/TC11631/rh80_ia32_O/default/WORK_DIR/tmp/xdelta-
root/usr/share/doc/xdelta-1.1.3
+ /bin/mkdir -p /netbatch/TC11631/rh80_ia32_O/default/WORK_DIR/tmp/xdelta-
root/usr/share/doc/xdelta-1.1.3
+ cp -pr NEWS README doc/xdelta.txt 
xdelta.magic /netbatch/TC11631/rh80_ia32_O/default/WORK_DIR/tmp/xdelta-
root/usr/share/doc/xdel
ta-1.1.3
cp: cannot stat `doc/xdelta.txt': No such file or directory
error: Bad exit status 
from /netbatch/TC11631/rh80_ia32_O/default/WORK_DIR/tmp/rpm-tmp.69093 (%doc)

I haven't found any xdelta.txt in package. Looks like you've missed it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb xdelta.spec

    

Actual Results:  Installation error

Expected Results:  Succesfully built & installed package.

Additional info:

Comment 1 Sysoltsev Slawa 2002-12-20 09:50:51 UTC
Created attachment 88831 [details]
Patch which removes need for xdelta.txt from .spec file

Comment 2 Jeff Johnson 2003-01-20 15:53:24 UTC
xdelta-1.1.3 builds fine with rpm-4.2-0.56.

Comment 3 Sysoltsev Slawa 2003-01-21 09:34:53 UTC
That's why you possibly have 
%_missing_doc_files_terminate_build 0
%_unpackaged_files_terminate_build 0
in your rpmmacro file (I have ones in /usr/lib/rpm/redhat/macros).

That't bad style to suppress packaging errors, at least you should try to build with 
these flags set; this helps you identify what files are missed and what are extras.


Comment 4 Jeff Johnson 2003-01-21 12:45:19 UTC
No, I am not configured that way.


Note You need to log in before you can comment on or make changes to this bug.