Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80109 - xml-common xmlcatalog some erroneous systemIdentifiers
Summary: xml-common xmlcatalog some erroneous systemIdentifiers
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: docbook-dtds
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-20 02:22 UTC by David Crossley
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-08 13:28:37 UTC


Attachments (Terms of Use)
plain-text patch generated using diff -u (deleted)
2002-12-20 02:28 UTC, David Crossley
no flags Details | Diff

Description David Crossley 2002-12-20 02:22:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Updated to xml-common-0.6.3-13.noarch.rpm and friends.
However the /usr/share/sgml/docbook/xmlcatalog does not work properly when i try
to process a docbook-4.1.2 xml instance. There are some systemIdentifiers that
point to the new 4.2 entities rather than the proper 4.1.2 versions.

Using Apache Forrest (Xerces-J and xml-commons Entity Resolver).
/usr/share/sgml/docbook/xml-dtd-4.2-1.0-15/dbcentx.mod:52:19: The entity
"sgml.features" was referenced, but not declared.
/usr/share/sgml/docbook/xml-dtd-4.2-1.0-15/dbcentx.mod:52:19: The markup
declarations contained or pointed to by the document type declaration must be
well-formed.

This is because xmlcatalog is point to 4.2/dbcentx.mod rather than to
4.1.2/dbcentx.mod

There are other similar issues (see attached patch).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See description above and fix attached.
    

Expected Results:  DTDs should be resolved to the relevant local copies.

Additional info:

Comment 1 David Crossley 2002-12-20 02:28:26 UTC
Created attachment 88822 [details]
plain-text patch generated using diff -u

Comment 2 Tim Waugh 2002-12-20 09:50:25 UTC
Fixed package is docbook-dtds-1.0-16, which will shortly appear in rawhide.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.