Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80105 - user accounts manager doesn't work in X, RH8
Summary: user accounts manager doesn't work in X, RH8
Keywords:
Status: CLOSED DUPLICATE of bug 73375
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-20 01:04 UTC by Zoltan Toroczkai
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:28 UTC


Attachments (Terms of Use)

Description Zoltan Toroczkai 2002-12-20 01:04:19 UTC
Description of problem:

Under X windows, RedHat 8.0, redhat-config-users does not work.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. log in as root
2. startx
3. try running redhat-config-users from a console/x-term, or using a mouse, 
from the desktop "Start Here/System Settings/Users and Groups"
    
Actual results:
An error message (when run from an x-term):

[root@bolyai root]# redhat-config-users
Traceback (most recent call last):
File "/usr/share/redhat-config-users/redhat-config-users.py", line 36, in ?
mainWindow.mainWindow()
File "/usr/share/redhat-config-users/mainWindow.py", line 257, in __init__
self.refresh()
File "/usr/share/redhat-config-users/mainWindow.py", line 422, in refresh
self.refresh_users()
File "/usr/share/redhat-config-users/mainWindow.py", line 331, in refresh_users
gidNumber = userEnt.get(libuser.GIDNUMBER)[0]
IndexError: list index out of range
[root@bolyai root]#


Expected results:
to start the user and groups manager window

Additional info:

Comment 1 Brent Fox 2002-12-22 16:56:21 UTC

*** This bug has been marked as a duplicate of 73375 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:28 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.