Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80075 - Getting error with indexmaker on RedHat 8.0
Summary: Getting error with indexmaker on RedHat 8.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mrtg
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-19 17:13 UTC by Richard Ackad
Modified: 2007-04-18 16:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-17 08:16:15 UTC


Attachments (Terms of Use)

Description Richard Ackad 2002-12-19 17:13:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Hotbar 
4.1.7.0; .NET CLR 1.0.3705)

Description of problem:
Hello,
When I use the "indexmaker" command with mrtg-2.9.17-8 (i.e. the version that 
comes on the RedHat 8.0 CD), I get the following error:

Can't locate package $VERSION for @MRTG_lib::ISA at /usr/bin/indexmaker line 49
        main::BEGIN() called at /usr/bin/../lib/mrtg2/MRTG_lib.pm line 49
        eval {...} called at /usr/bin/../lib/mrtg2/MRTG_lib.pm line 49

Could someone help me.
Thanks,
Rico

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. I use the "cfgmaker" command to create the .cfg file
2. I use the "mrtg" command to generate the graphs
3. I use the "indexmaker" command to generate the .html file
    

Additional info:

Comment 1 Brian Marsden 2002-12-21 08:30:26 UTC
The problem appears to be due to indemaker/mrtg not being 100% compatible with
perl 5.8. See:

http://groups.google.co.uk/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=slrnarjl4g.q36.mgjv%40martien.heliotrope.home

which states that we should be using a newer version of mrtg.

Any chance of an errata update for mrtg, RedHat?

Comment 2 Bishop Clark 2003-07-07 05:15:22 UTC
an update to makemaker will fix this problem.

in fact, a cpam2rpm --shadow of MakeMaker will probably work around it nicely.

It did for me under perl 580 on rh62.

Comment 3 Miloslav Trmač 2004-08-17 08:16:15 UTC
I can't reproduce this problem with FC2 mrtg-2.10.5-3,
please reopen if you still can experience this error with
a recent package.



Note You need to log in before you can comment on or make changes to this bug.