Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80062 - olddir doesn't allow relative pathnames
Summary: olddir doesn't allow relative pathnames
Keywords:
Status: CLOSED DUPLICATE of bug 79936
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logrotate
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-19 13:49 UTC by David Alden
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:27 UTC


Attachments (Terms of Use)

Description David Alden 2002-12-19 13:49:33 UTC
Description of problem:
"olddir" doesn't allow relative pathnames -- even though it (looks like it)
is supposed to.  I commented out the code in config.c that checks for
the existence of the directory, and everything else worked just fine.  I need
this so I can do something like:

/var/syslog/*/* {
  olddir old
}

and have logrotate place the old logfiles in their respective old directories.


Version-Release number of selected component (if applicable):
3.6.5 and 3.6.6 (didn't check older versions)


How reproducible:
Create a config file with "olddir relative/path".


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Elliot Lee 2003-01-14 18:25:03 UTC

*** This bug has been marked as a duplicate of 79936 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:27 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.