Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80027 - no valid devices
Summary: no valid devices
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 7.3
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-18 22:12 UTC by Tom Borneman
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-19 16:21:19 UTC


Attachments (Terms of Use)

Description Tom Borneman 2002-12-18 22:12:08 UTC
Description of problem:


When trying to kickstart install a server, I get the following error:
"An error has occurred - no valid devices were found on which to create
new filesystem"

I've already installed RedHat 7.3, manually, on this system.  It has an
Intel L440GX+ motherboard with an embedded AIC-7896 Adaptec SCSI controller.
The installation went fine.

I have several other systems identical to this.  So, I've created a kickstart
file from the anaconda-ks.cfg file from the first install.

I tried it with and without the "apic" options at the boot prompt.

My disk configuration section of my kickstart file looks like this:

clearpart --all
part /boot --fstype ext3 --size=2048 --ondisk=sda
part / --fstype ext3 --size=6144 --ondisk=sdb
part swap --size=2048 --ondisk=sda
part swap --size=2048 --ondisk=sda
part raid.14 --size=1024 --grow --ondisk=sdb
part raid.12 --size=1024 --grow --ondisk=sda
raid /ptmp --fstype ext3 --level=RAID0 raid.12 raid.14

I've also tried it without the "=" on the --ondisk option (that's what the
https://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/custom-guide/s1-kickstart2-options.html
states).

I've also tried commenting out the disk portion of the kickstart file so I can
go into interactive mode during that part, but, I get the same results.

Version-Release number of selected component (if applicable):

kickstart installation of RedHat 7.3

How reproducible:

Try installing via kickstart.

Steps to Reproduce:
1. Have a system with an AIC-7896 Adaptec SCSI controller.
2. Create a kickstart file
3. Try installing.
    
Actual results:

An error has occurred - no valid devices were found on which to create new
filesystem

Expected results:

Start installation of system.

Additional info:

Comment 1 Tom Borneman 2002-12-19 16:20:41 UTC
Please close this bug.  Sorry for openning it.  I had a case of
cranial-rectitus (my head up my butt).  I was trying to use a
7.2 bootnet image to install 7.3.

Sorry 'bout that.

Comment 2 Michael Fulbright 2002-12-20 17:38:25 UTC
Time tracking values updated


Note You need to log in before you can comment on or make changes to this bug.