Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80022 - RedHat Linux 8.0 install via nfs fails
Summary: RedHat Linux 8.0 install via nfs fails
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 8.0
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
Depends On:
TreeView+ depends on / blocked
Reported: 2002-12-18 21:45 UTC by Need Real Name
Modified: 2007-04-18 16:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-04-24 18:42:36 UTC

Attachments (Terms of Use)
anaconda traceback dump (deleted)
2003-01-02 16:44 UTC, Need Real Name
no flags Details
anaconda dump installing from NFS mounted iso files (deleted)
2003-01-02 16:45 UTC, Need Real Name
no flags Details

Description Need Real Name 2002-12-18 21:45:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4)
Gecko/20011128 Netscape6/6.2.1

Description of problem:
RedHat Linux 8.0 install via nfs fails

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Steps to Reproduce:
1. Build 8.0 repository subdirectory OR use iso image repository per RedHat
2. Build bootdisk (bootnet.img) or use PXE boot (has worked great for us with 7.3)
3. Start the install selecting either Workstation or Custom. Errors out after
setting root password page and hitting next.


Actual Results:  Actual Results:
Traceback (most recent call last):
  File "/usr/lib/anaconda/", line 632, in nextClicked
  File "/usr/lib/anaconda/", line 150, in gotoNext
  File "/usr/lib/anaconda/", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/", line 121, in readPackages
  File "/usr/lib/anaconda/installclasses/", line 15, in
    personal_desktop.InstallClass.setGroupSelection(self, comps)
  File "/usr/lib/anaconda/installclasses/", line 33, in
    comps["Workstation Common"].includeMembers()
  File "/usr/lib/anaconda/", line 580, in __getitem__
    return self.compsDict[key]
KeyError: Workstation Common

Expected Results:  Expected Results:
successful installation

Additional info:

Additional Information:
We have rebuilt the nfs mounted repository several times. we've tried installing
by pointing to mounted isoimage directory and we've double checked our nfs server.
I have the entire anacdump.txt file saved if you need it.

Comment 1 Michael Fulbright 2002-12-19 15:09:49 UTC
The error log file would be appreciated.

Comment 2 Need Real Name 2003-01-02 16:38:48 UTC
Adding other previous comments from ltc1415
------- Additional Comment #7 From Salina Chu(  2002-10-22
12:40 -------

I was able to use NFS to install RedHat 8.0 by doing 
1. use the bootnet.img to create floppy image, install from floppy
2. use update image mentioned in RedHat bugzilla to create update floppy image
8.0-cdread.img has anaconda updates on that disk
3. At boot prompt, type linux updates 
   ( as the install continues, at some point during the install, 
     it will prompt you for the
     update image floppy disk )
4. On the NFS server, while following RedHat install instructions
   to create the NFS install tree, 
   I noticed copying 2nd and 3rd binary disk
   overlayed TRANS.TBL.   I copied the files from the 1st binary disk back 
   since the first disk is usually used for install.

Jeff was able to use my instructions and my NFS server to install his machine.
He is now trying to fix his NFS server and re-try install.

------- Additional Comment #9 From Jeff Martin(  2002-10-22
13:49 -------

Copied the TRANS.TBL files from CD1 to proper locations on nfs repository. This
didn't fix the problem. Looks like anaconda changes on the update disk are going
to be the solution. Creating RHupdates directory on nfs repository to put the
update image in. Will see if that will allow automated nfs installs.

------- Additional Comment #10 From Jeff Martin( 2002-10-22
16:05 -------

Found reference in to
TRANS.TBL problems. I deleted all of the TRANS.TBL files from RedHat 8.0 nfs
repository and the installs work now.
I am inclined to believe that there is a defect in anaconda associated with
attempts to use TRANS.TBL in an nfs install.

------- Additional Comment #11 From Salina Chu( 2002-10-22
16:08 -------

Found description of what TRANS.TBL is 


------- Additional Comment #12 From Salina Chu( 2002-10-22
16:09 -------

Ooops.  left the h out in http

Found description of what TRANS.TBL is

------- Additional Comment #18 From Salina Chu(  2002-10-22
18:31 -------

We also tried to install from NFS directory that just has the iso images in 
there.  This type of NFS install did not work.
I had already attached another anacdump file, please send that to RedHat.

------- Additional Comment #19 From Salina Chu( 2002-10-23
11:44 -------

I moved cd4-6 iso files ( source ISO images ) to another file system.
Using NFS images + using updates floppy,  I am able to install RH 8.0 
workstation.   Will try all packages and without using updates floppy later. 

------- Additional Comment #20 From Salina Chu( 2002-10-23
15:57 -------

I can install using NFS iso images, but only using iso 1-3.
I can do custom install, choose everything, did not need to use updates floppy 

------- Additional Comment #23 From Salina Chu( 2002-12-18
18:22 -------

We had found work arounds for the NFS install - we said that in previous 
appends.   The work arounds are 
(1) remove all the TRANS.TBL files from the expanded install tree
(2) If using ISO files, only have first 3 ISO files on the NFS mounted dir.

This is why Jeff lowered the severity from blocking to regular because he can 
install using NFS by using work around (1).

RedHat should either fix the documentation on NFS install or fix the installer 

Comment 3 Need Real Name 2003-01-02 16:44:26 UTC
Created attachment 89058 [details]
anaconda traceback dump

anaconda traceback dump

Comment 4 Need Real Name 2003-01-02 16:45:24 UTC
Created attachment 89059 [details]
anaconda dump installing from NFS mounted iso files

anaconda dump installing from NFS mounted iso files

Comment 5 Jeremy Katz 2003-01-10 06:45:20 UTC
The problem was that you had the documentation CDs in the same directory.  There
is code in our current codebase to handle this properly.

Comment 6 Need Real Name 2003-01-28 23:17:04 UTC
Adding another comment from ltc1415:
There are 2 ways to do NFS install,
(1) Expand ISO files into directory trees
    - we found we had to remove TRANS.TBL files before this method works
(2) use iso images only
    - we found we had to remove doc iso images from the directory before this
      method works
your last append sounds like RedHat fixed one way of installing - method (2).

How about the expanded tree way ? i.e. why do I need to remove the TRANS.TBL 
files ?   Is that fixed ? or are they changing documentation telling people to 
remove those files first before using NFS install ?


Comment 7 Jeremy Katz 2006-04-24 18:42:36 UTC
Mass-closing lots of old bugs which are in MODIFIED (and thus presumed to be
fixed).  If any of these are still a problem, please reopen or file a new bug
against the release which they're occurring in so they can be properly tracked.

Note You need to log in before you can comment on or make changes to this bug.