Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 80017 - Absoft can't find errno!
Summary: Absoft can't find errno!
Keywords:
Status: CLOSED DUPLICATE of bug 80016
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-18 20:05 UTC by Sammy
Modified: 2016-11-24 15:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:24 UTC


Attachments (Terms of Use)

Description Sammy 2002-12-18 20:05:34 UTC
The Asbsoft Fortran 95 compiler for linux is giving an error which started 
recently in rawhide. Which library is errno in now? Thanks 
 
================================================= 
f95 -o ../../run/dws.exe grid_def_2d_cyl_v32.o   spinor_def_2d_cyl_v24.o 
special_functions_v12.o  dws_v35.o  ../spline90/spline90.a /usr/lib/lapack95_intel.a 
/usr/lib/libmkl_lapack.a /usr/lib/libmkl_p4.a -lf2c -lm -lpthread 
/usr/absoft/lib/libfio.a(ioerr.o)(.text+0x233): In function `_ioerr': 
: `sys_errlist' is deprecated; use `strerror' or `strerror_r' instead 
/usr/absoft/lib/libfio.a(open.o)(.text+0xdbd): In function `_f_open3': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0xf9): In function `_getfile': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0x141): In function `_releasefile': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0x16c): In function `_releasefile': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0x1dc): In function `_f_seek': 
: undefined reference to `errno' 
/usr/absoft/lib/libfio.a(lowlevel.o)(.text+0x223): more undefined references to `errno' follow

Comment 1 Jakub Jelinek 2002-12-18 20:08:29 UTC

*** This bug has been marked as a duplicate of 80016 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:24 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.