Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79972 - Segmentation fault when sshing an hostname with no address associated
Summary: Segmentation fault when sshing an hostname with no address associated
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openssh
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-18 08:47 UTC by Nicolas Mailhot
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-08 08:46:04 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2002-12-18 08:47:35 UTC
On RH8, when sshing an hostname with no address associated, I get a :

[nim@poseidon nim]$ ssh fr
ssh: fr: No address associated with hostname

(openssh-3.4p1-2)

On Rawhide (same user and nfs-mounted home) :

[nim@ulysse nim]$ ssh -v fr
OpenSSH_3.5p1, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
debug1: Reading configuration data /home/nim/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: ssh_connect: needpriv 0
Erreur de segmentation

(openssh-3.5p1-2)

Don't know if it's serious or purely cosmetic, but a core command as ssh should
be crashproof IMHO

Comment 1 Brian Brock 2003-01-08 00:58:22 UTC
I can't replicate this error (same version of ssh, more recent versions of many
underlying packages like glibc), I get a sane exit without segmentation fault.

Is the error occuring?  If so, is there more background information you can
provide on the system's configuration (changes from default setup in openssh,
any libraries not from the current rawhide)?

Comment 2 Nicolas Mailhot 2003-01-08 08:46:04 UTC
I can't reproduce it either now. My openssh version didn't change ; however I
did a couple of rawhide syncs since the report, so probably the problem was in
another rpm that changed since then. I'll close the bug.


Note You need to log in before you can comment on or make changes to this bug.