Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79967 - popup windows should be set to transient
Summary: popup windows should be set to transient
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-18 07:06 UTC by Tammy Fox
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version: 0.6.24-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-02-27 06:21:54 UTC


Attachments (Terms of Use)

Description Tammy Fox 2002-12-18 07:06:20 UTC
Since they are set modal, all popup dialogs should be set to transient so it
can't appear below the parent window (which makes it look like the app locked up
if you have windows between the parent and the child windows).

This can be done with dlg.set_transient_for(parent_widget), where you replace
dlg and parent_widget with your variable names.

Comment 1 Tim Waugh 2002-12-18 16:34:32 UTC
Fixed in CVS.

Comment 2 Tim Waugh 2002-12-18 16:58:54 UTC
0.6.24-1

Comment 3 Tammy Fox 2004-02-27 06:21:54 UTC
Confirmed. Looks fixed to me.


Note You need to log in before you can comment on or make changes to this bug.