Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79950 - redhat-config-packages crashes: Unknown Error
Summary: redhat-config-packages crashes: Unknown Error
Keywords:
Status: CLOSED DUPLICATE of bug 80283
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-18 05:12 UTC by Michael Fulbright
Modified: 2008-05-01 15:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:24 UTC


Attachments (Terms of Use)

Description Michael Fulbright 2002-12-18 05:12:04 UTC
If you run redhat-config-packages it dies with a dialog saying "Unknown error.".

Comment 1 Jeremy Katz 2002-12-18 05:49:54 UTC
There are also a number of Glib-GObject-WARNINGs

Glib-GObject-WARNING: invalid uninstantiatable type 'GBoxed' in cast to 'GtkObject'

GLib-GObject-WARNING: instance of invalid non-instantiatable type 'gint64'

GLib-GObject-CRITICAL: file gsignal.c: line 2056 (g_signal_handlers_destroy):
assertion G_TYPE_CHECK_INSTANCE (instance) failed

And then it segfaults.  Rebuilding of pygtk2 and glade doesn't seem to have any
effect, so I'm not quite sure what's going on here.  Any thoughts?

Comment 2 Jeremy Katz 2002-12-18 05:52:26 UTC
And it's reproducible with just

#!/usr/bin/python
import gtk
i = gtk.Invisible()

Comment 3 Jeremy Katz 2002-12-27 17:18:23 UTC
Consolidating by duping against the public bug

*** This bug has been marked as a duplicate of 80283 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:50:24 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Comment 5 David Lawrence 2006-04-24 19:03:29 UTC
Adding to blocker bug 185486 and adding IBM group.

Comment 6 David Lawrence 2006-04-24 19:28:54 UTC
OOps. Sorry for the mistake. I searched by the wrong list and mistakenly made
these changes. Sorry for the spam. Removing from blocker bug 185486 and to IBM
confidential group.

Comment 7 David Lawrence 2006-04-24 19:45:28 UTC
The last changes to these bugs were mistakenly made. Removing incorrect blocker
bug and confidential group.


Note You need to log in before you can comment on or make changes to this bug.