Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79936 - 'olddir' handling is broken
Summary: 'olddir' handling is broken
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: logrotate
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Jay Turner
URL:
Whiteboard:
: 80062 (view as bug list)
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-18 04:06 UTC by Enrico Scholz
Modified: 2015-01-08 00:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 18:26:56 UTC


Attachments (Terms of Use)
Patch against logrotate-3.6.6 fixing olddir-behavior (deleted)
2002-12-25 18:59 UTC, Enrico Scholz
no flags Details | Diff

Description Enrico Scholz 2002-12-18 04:06:12 UTC
Description of problem:

logrotate creates error-messages like:

| error: amd:4 error verifying olddir path /var/log//var/log/.old: No such file
or directory

'olddir' is set by /etc/logrotate.d/00options:
| olddir /var/log/.old                                                         
                        

/etc/logrotate.d/apm does not contain an 'olddir' specification


Version-Release number of selected component (if applicable):

logrotate-3.6.6-1


How reproducible:

100%

Comment 1 Enrico Scholz 2002-12-25 18:59:22 UTC
Created attachment 88905 [details]
Patch against logrotate-3.6.6 fixing olddir-behavior

The attached patch fixes the following issues:
* the check if olddir is an absolute or relative path was broken
* the check if olddir and logfile are on the same device happened too early

Comment 2 Elliot Lee 2003-01-14 18:25:06 UTC
*** Bug 80062 has been marked as a duplicate of this bug. ***

Comment 3 Elliot Lee 2003-01-14 18:26:56 UTC
Applied, thanks.


Note You need to log in before you can comment on or make changes to this bug.