Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79901 - Neat not saving static network route settings
Summary: Neat not saving static network route settings
Keywords:
Status: CLOSED DUPLICATE of bug 76267
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-17 21:41 UTC by Tim Jensen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:22 UTC


Attachments (Terms of Use)

Description Tim Jensen 2002-12-17 21:41:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I added a network route to static network routes under neat. When saving, I got
a bugzilla report. It did save but then i couldnt delete it. I could modify it
and it would save those changes but i couldnt get rid of it. I finally had to do
it by hand in the network-routes file. That removed the entry but my NIC was
still screwed. Some file was messed up. My NIC would light and i could activate
it if i unplugged the ethernet cable and used my second NIC in my box. To solve
the problem i had to uninstall the device and driver and reinstall it anew. Then
i used the second NIC to activate the first one and then i switched the cable.
The first NIC worked perfectly again. Ill attach the bug report. Thanks for all
your work on bugs. Its really appreciated!! 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.add static network route
2.might try 182.168.1.1 or 0.0.0.0 which really screws with it
3.
    

Actual Results:  unable to delete the address and corruption of some basic file
not sure what

Expected Results:  address deleted, the change saved so there are no addresses
in the static network routes

Additional info:

Traceback (most recent call last):
  File "/usr/sbin/neat", line 689, in on_deviceActivateButton_clicked
    if self.save() != 0:
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 58,
in network
    self.prefix()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 37,
in prefix
    self._netmask = re.match("NETMASK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'

Local variables in innermost frame:
text: 
self: <netconfpkg.ipcalc.IPCalc instance at 0x874969c>

Comment 1 Harald Hoyer 2003-01-09 13:59:50 UTC

*** This bug has been marked as a duplicate of 76267 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.