Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79896 - grubby --bootloader-probe fails to find lilo with software raid
Summary: grubby --bootloader-probe fails to find lilo with software raid
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-17 21:31 UTC by Philip Ross
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-14 22:19:33 UTC


Attachments (Terms of Use)
My /etc/raidtab (deleted)
2003-01-14 21:55 UTC, Philip Ross
no flags Details

Description Philip Ross 2002-12-17 21:31:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Versions 21.4.3 and up of lilo have support for automatically working out where
to install the bootloader in RAID 1 setups. This allows you to set boot=/dev/mdX
(where mdX is the /boot partition) and have lilo automatically install the
bootloader to the boot sectors of the drives making up the RAID array. See
http://www.elliott-turbo.com/lilo/.

When lilo.conf includes the line boot=/dev/mdX, 'grubby --bootloader-probe' will
fail to return 'lilo' as expected since the bootloader has been installed to
/dev/hdX instead of /dev/mdX. If the lilo.conf file is changed so boot=/dev/hdX,
'grubby --bootloader-probe' works as expected (returning 'lilo').

This problem prevents kernel and other upgrades from reinstalling lilo when
required.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat with a RAID 1 mirrored /boot partition.
2. Setup lilo using boot=/dev/mdX and install.
3. Run grubby --bootloader-probe which will not return anything.
4. Setup lilo using boot=/dev/hdX and reinstall.
5. Run grubby --bootloader-probe. This will now return 'lilo'.
    

Actual Results:  Step 3:

#grubby --bootloader-probe

<returns nothing>

Expected Results:  Step 3:

#grubby --bootloader-probe
lilo


Additional info:

Comment 1 Philip Ross 2002-12-17 22:23:35 UTC
I've just done a little investigation into the source for grubby and the problem
is that bootSect is read from the first 512 bytes of /dev/mdX, whereas lilo
actually installs itself to the boot sectors of the drives making up /dev/mdX
(e.g. /dev/hda and /dev/hdb). When boot is set to /dev/hda in lilo.conf, grubby
works correctly as bootSect is read from the first 512 bytes of /dev/hda.

Comment 2 Erik Troan 2003-01-14 21:36:16 UTC
do you have a correct /etc/raidtab sitting around?

Comment 3 Philip Ross 2003-01-14 21:55:05 UTC
Created attachment 89363 [details]
My /etc/raidtab

I've attached my current /etc/raidtab. With this RAID 1 setup 'grubby
--bootloader-probe' fails.

Comment 4 Erik Troan 2003-01-14 22:19:33 UTC
this should be fixed in mkinitrd > 3.4.43 -- want me to send you an rpm to test?

Comment 5 Philip Ross 2003-01-14 22:39:56 UTC
Yes please.

Comment 6 Jeremy Katz 2003-01-14 22:48:32 UTC
http://people.redhat.com/~katzj/mkinitrd/ has the newer package.

Comment 7 Philip Ross 2003-01-14 23:04:13 UTC
Thanks. The new version returns the correct result on my RAID 1 setup using lilo.

Will this fix be made available as an errata package for Redhat 8.0?


Note You need to log in before you can comment on or make changes to this bug.