Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79878 - Up2date --nox is ignored
Summary: Up2date --nox is ignored
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date
Version: 2.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-17 19:39 UTC by Mike Gahagan
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-15 04:42:02 UTC


Attachments (Terms of Use)

Description Mike Gahagan 2002-12-17 19:39:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
up2date will under certain situations completely ignore --nox and fail to run
because of X11 authentication errors. The sshd on the server described below is
configured in a totally stock manner.

Version-Release number of selected component (if applicable):

up2date-2.7.61-7.x.2 on AS 2.1 w/ all applicable errata

How reproducible:
Always

Steps to Reproduce:
1.Install AS 2.1
2.Apply all errata (as of 12-2002)
3.Attempt to run up2date through a remote ssh session
    

Actual Results:  [mpg@prowler mpg]$ ssh mpg@phoenix.rdu.redhat.com
mpg@phoenix.rdu.redhat.com's password:
Last login: Tue Dec 17 14:28:35 2002 from prowler.rdu.redhat.com
[mpg@phoenix mpg]$ su -
Password:
[root@phoenix root]# up2date
X11 connection rejected because of wrong authentication.
Gdk-ERROR **: X connection to localhost:10.0 broken (explicit kill or server
shutdown).
[root@phoenix root]# up2date --nox
X11 connection rejected because of wrong authentication.
Gdk-ERROR **: X connection to localhost:10.0 broken (explicit kill or server
shutdown).
[root@phoenix root]# up2date -u --nox
X11 connection rejected because of wrong authentication.
Gdk-ERROR **: X connection to localhost:10.0 broken (explicit kill or server
shutdown).


Expected Results:  up2date --nox should have worked regardless of if an X
display is available or not. (In this case X was not available, no X app will
run until the root shell is exited)

Additional info:

I got the same results regardless if a user was logged into the console or not.
I understand that logging in via ssh and running su - will cause X
authentication problems that prevent X displays from being forwarded, but --nox
should not care about if X11 is available or not.

running 'up2date --nox' as a normal user will present a GUI password dialog to
the client, upon successfull authentication it will proceed to work in text
mode. I feel this is also broken.. i.e. I shouldn't be using X to pop up a
password window when I specify --nox.

Comment 1 Adrian Likins 2003-01-15 04:42:02 UTC
fixed with a change to userhelper circa 8.0. 

This is a userhelper bug. It doesnt understand
the concept of "--nox". It decided to pop up
a gui window or not itself (in 7.x/2.1AS)

The 8.0 version fixes this. As far as I know,
there are no plans to backport this bug fix.

Comment 2 Mike Gahagan 2003-01-15 18:12:53 UTC
Thanks Adrian!

I never thought to look into it to see if it was userhelper and not up2date. 

/usr/sbin/up2date [options] does in fact work as expected when run as root (even
without --nox) on AS w/ errata.




Note You need to log in before you can comment on or make changes to this bug.