Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79875 - 2.4.18-18.8.0 doesn't run smp code
Summary: 2.4.18-18.8.0 doesn't run smp code
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-17 18:45 UTC by Joshua Weage
Modified: 2016-11-24 14:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-03 10:22:37 UTC


Attachments (Terms of Use)

Description Joshua Weage 2002-12-17 18:45:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I'm running LS-Dyna on dual CPU Athlon machines.  RedHat 7.3 runs the code fine
with both release kernels.  RedHat 8.0 with 2.4.18-18.8.0 runs the code, but
with only one cpu.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Run LS-Dyna with multi-cpu's.
2.
3.
    

Additional info:

Comment 1 Ben LaHaise 2002-12-17 20:39:38 UTC
Check your /proc/cpuinfo.  If two CPUs are present, the kernel is working fine,
and the bug is in some other code, probably the application.

Comment 2 Joshua Weage 2002-12-17 23:21:59 UTC
I am seeing 2 cpu's displayed while running top, so the kernel is detecting them
both.  I find it strange that the application runs fine with 7.3 2.4.18-3 and
2.4.18-18.7.x kernels, but not the 8.0 2.4.18-18.8.0 kernel -- on identical
hardware.

Considering all of the other bugs I've ran into with the 8.0 release, it may not
be kernel related.  Maybe it is something with the thread library?  I'm not at
work currently, so I can't check what libraries it is using.  Anyway, I wanted
to log this problem as I didn't see anything else like it logged already.

Comment 3 Arjan van de Ven 2002-12-17 23:24:19 UTC
2.4.18-18.7.x and 2.4.18-18.8.0 are identical source code wise
which means it's not going to be a kernel bug....
reassigning to glibc since that's the next candidate

Comment 4 Ulrich Drepper 2003-04-22 07:50:31 UTC
Try this on RHL9.  I have no idea what should be the reason.  You should dig in
the code and determine where it is decided in the code that only one thread (or
process) is used.  If the program is using more than one thread/process
definitely all processors are used.  It either seems to be a problem in the
application code where it tries to find out how many processors are used, or a
hiccup in the runtime function which allows to determine this (there is only one
such function: sysconf).

Comment 5 Ulrich Drepper 2003-10-03 10:22:37 UTC
No response in almost 6 months.  Closing as NOTABUG since the runtime definitely
doesn't restrict an application to run on one processor.  If that kernel already
supported the affinity syscalls (I don't know whether it did) then it must be
the application which choses to use those.  The runtime _never_ uses them on its
own.


Note You need to log in before you can comment on or make changes to this bug.