Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79871 - rpm-4.2: rpmbuild segfault with AutoReq: 0 (sometimes)?
Summary: rpm-4.2: rpmbuild segfault with AutoReq: 0 (sometimes)?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-build
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-17 18:13 UTC by Jeff Johnson
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-27 20:56:25 UTC


Attachments (Terms of Use)

Description Jeff Johnson 2002-12-17 18:13:28 UTC
Internally generated dependencies segfault when built
by beehive (but not from rpmbuild) for redhat-artwork-0.49-3
when built with debug-subpackage turned on.

Hmm, smells like uninitialized pointer not getting filled
in if
     AutoReq: 0
is specified.

Comment 1 Jeff Johnson 2002-12-27 20:56:25 UTC
This no longer segfaults if built with internal dependencies]
using rpm-4.2-0.40, assuming fixed (since I can't reproduce).


Note You need to log in before you can comment on or make changes to this bug.