Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79869 - neat doesn't allow configuration of Transmit Rate and Channel for cisco aironet 350
Summary: neat doesn't allow configuration of Transmit Rate and Channel for cisco airon...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 73417 (view as bug list)
Depends On:
Blocks: 81720
TreeView+ depends on / blocked
 
Reported: 2002-12-17 17:43 UTC by Dennis Edmonds
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-05 13:07:24 UTC


Attachments (Terms of Use)

Description Dennis Edmonds 2002-12-17 17:43:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When using neat or redhat-config-network to install and configure a Cisco
Aironet 350, the gui does not allow the Transmit Rate or the Channel variables
to be set.  The default seems to CHANNEL=1 and RATE=11Mb/s, which will not work
on our specific wireless network.  (Maybe it works for some people, just nowhere
I have tried the card.)  After editing /etc/sysconfig/network/ifcfg-eth1 and
changing the CHANNEL setting to 6 and the RATE setting to Auto....everything
works fine.  Although you can actually get by with leaving the channel set to 1,
the rate absolutely has to be set for Auto.

I resolved this issue after after installing the Cisco provided driver for the
card and taking note of the defaults they use for the Rate setting.  I don't
know why the neat GUI will not allow you to change the Channel and Rate, but if
the default Rate was set to auto this would at the very least allow the card to
work "out of the box."

I hope this is clear enough, if you need further information please let me know.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Cisco Aironet 350 PCMCIA adapter into laptop
2. Start up redhat-config-network.
3. Add a wirekess adapter.
4. Look at the crazy default rate setting for the card.
5. Agonize over not being able to change it in the GUI :)
    

Actual Results:  The card didn't work.

Expected Results:  The card should work.

Additional info:

correct defaults for /etc/sysconfig/network-scripts/ifcfg-eth#:

USERCTL=no
PEERDNS=yes
GATEWAY=
TYPE=Wireless
DEVICE=eth1
HWADDR=00:0a:8a:fa:98:fb
BOOTPROTO=dhcp
NETMASK=
ONBOOT=no
DHCP_HOSTNAME=
IPADDR=
NAME=
DOMAIN=
ESSID=(kind of private)
CHANNEL=1
MODE=Managed
KEY=(kind of private)
RATE=Auto

Comment 1 Harald Hoyer 2003-02-05 13:07:24 UTC
huh? Channel and Rate are configureable in the GUI!

Comment 2 Dennis Edmonds 2003-02-05 15:56:50 UTC
I can change the channel and rate on all of the other cards at the office, but
not on this particular Cisco Aironet card.  I can send you screenshots of the
greyed out channel and rate fields in the gui if that will help?

Dennis


Comment 3 Harald Hoyer 2003-02-06 10:17:57 UTC
is it only greyed out in the channel or in the normal "Edit"-dialog, too?

Comment 4 Dennis Edmonds 2003-02-06 16:49:14 UTC
It is greyed out when I run neat, highlight the wireless card, click on edit,
and go to the Wireless Settings tab.  Is there somewhere else in neat that I can
view the channel and rate setting?  I've always looked at it here...



Comment 5 Alan Cox 2003-06-05 19:07:17 UTC
*** Bug 73417 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.