Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79862 - Remembered queries using "reported by" aren't migrated correctly
Summary: Remembered queries using "reported by" aren't migrated correctly
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: 2.17
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-17 16:48 UTC by Glen A. Foster
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-11 18:07:08 UTC


Attachments (Terms of Use)

Description Glen A. Foster 2002-12-17 16:48:23 UTC
Description of problem: I've discovered a problem with remembered queries in 
this migration from 2.8 to 2.17.1 -- if you have a remembered query in 2.8 that 
includes a "reported by" field, the migration to 2.17 causes these queries to 
not work.

How reproducible: Very much

Steps to Reproduce:
1. Create and save a named query using bugzilla 2.8 as described below
2. Run this query on bugzilla 2.17.1
3. Watch it not work
    
Additional info:
I defined 2 queries that don't work:

1a. Product=Red Hat {Linux,Linux Beta,Powertools,Powertools Beta,Ready Cert}
1b. Version,Arch,Status all blank (e.g., choose "any")
1c. Reported-by field is "glen.foster@hp.com"

... and named the above query "my-bugs-all"

2a. Product=Red Hat {Linux,Linux Beta,Powertools,Powertools Beta,Ready Cert}
2b. Version,Arch all blank (e.g., choose "any")
2c. Status is all but RESOLVED,CLOSED (e.g., select an open bug)
2d. Reported-by field is "glen.foster@hp.com"

... and named the above query "my-bugs-open"

When I used these queries, they both took a long time and yielded basically an 
empty page.  On a whim, I "load"ed them instead of "run"ning them.  The portion 
of the loaded query page that refers to "reporter is" field sets the SECOND set 
(e.g., not the left-most set)... if I change them to be the left-most set of 
widgets, the queries work.

This is more-or-less informational, but for those people who have named queries 
that use themselves (or anyone else, for that matter) as a reported-by field, 
these queries do not "automagically" translate over to the 2.17.1 query format.

Comment 1 David Lawrence 2002-12-17 21:36:09 UTC
If you first load these previously saved queries in the query page and then hit
search, do they then run properly? There seems to be some subtle difference with
the way the new bugzilla handles email searches which are failing with the older
queries. If it does then work for you, you can resave them by just putting the
same query name in the text box on the query page which will overwrite the old one.

Comment 2 Glen A. Foster 2003-04-11 18:07:08 UTC
Well, it certainly took me long enough to reply. :( :)  I re-entered the queries
and they work OK now.  I'm going to close this bug.


Note You need to log in before you can comment on or make changes to this bug.