Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79845 - Package info (from rpmquery -i) incorrect
Summary: Package info (from rpmquery -i) incorrect
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: units
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Ben Levenson
URL:
Whiteboard:
: 100404 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-17 14:19 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-11-09 19:03:03 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-17 14:19:10 UTC
Description of problem:
The 'units' package description states that the program "can only handle
multiplicative scale changes" whereas the man page states that that is not the
case, and even gives an example (which works) to contradict that.

Version-Release number of selected component (if applicable):
1.74-4

How reproducible:
rpmquery -i units
 
Actual results:
"Units can only handle multiplicative scale changes (i.e., it can not tell you
how to convert from Celsius to Fahrenheit, which requires an additive step in
addition to the multiplicative conversion)."

Expected results:
"The `units' program can handle multiplicative  scale  changes  as  well  as
nonlinear conversions such as Fahrenheit to Celsius."

Comment 1 Miloslav Trmac 2002-12-18 12:55:03 UTC
Farenheit to Celsius definitely _is_ linear. It's just y = Ax +B.


Comment 2 Need Real Name 2002-12-18 18:57:56 UTC
The point, in case it wasn't clear enough already, is that the two texts are
contradictory, and that the package description would lead one to believe that
it cannot be used for that type of conversion -- whereas it can.

Comment 3 Harald Hoyer 2003-01-07 16:01:35 UTC
fixed in 1.80-3

Comment 4 petrosyan 2003-05-24 19:25:52 UTC
A linear transformation T has the property that T(x+z)=T(x)+T(z).
(That's part of the definition of linear transformation.)  If you try
your form T(x)=ax+b you'll find that T(x)+T(z)=ax+b+az+b=a(x+z)+2b but
T(x+z)=a(x+z)+b.  So the property does NOT hold, and hence the form
T(x)=ax+b is NOT a linear transformation.  The Fahrenheit to Celsius
transformation y=ax+b is an affine transformation.


http://mathworld.wolfram.com/LinearTransformation.html
http://mathworld.wolfram.com/AffineTransformation.html
http://algebra.math.ust.hk/matrix_linear_trans/02_linear_transform/lecture3.shtml
http://www.instantweb.com/foldoc/foldoc.cgi?affine+transformation

Comment 5 Harald Hoyer 2003-08-05 08:03:04 UTC
*** Bug 100404 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.