Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79822 - Acroread's "userFrontEndProgram" flag doesn't work
Summary: Acroread's "userFrontEndProgram" flag doesn't work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: plugger
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-17 03:49 UTC by Dmitry Bolkhovityanov
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-17 15:32:16 UTC


Attachments (Terms of Use)

Description Dmitry Bolkhovityanov 2002-12-17 03:49:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

Description of problem:
The /etc/pluggerrc contains 

-xrm '*userFrontEndProgram: FALSE' 

in the acroread command line.  However, with at least acroread-4.05 this flag
doesn't work.

Changing this to "+useFrontEndProgram" (see "acroread -helpall") does the job.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Give two users (let them be "bill" and "bob") access to the display.
2. Open acroread under first user ("bill").
3. Start Mozilla under another user ("bob") and point it to some PDF file on the
web.

Actual Results:  Acroread says that it can't open the file -- "Permission denied"

Expected Results:  The file should open without any problems.

Additional info:

The problem is that if acroread is already started under "bill", that instance
of the program will be used, but "bill" doesn't have access to "bob"'s .mozilla/
(and .netscape/) directory.

The same will happen if acroread was previously launched from one machnie, and
mozilla/netscape -- from another: these programs live in distinct filesystem trees.

Comment 1 Ngo Than 2002-12-17 15:32:16 UTC
It's fixed in 4.0-22. many thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.