Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79798 - If epic is to replace ircii, it needs to answer to the name "irc"
Summary: If epic is to replace ircii, it needs to answer to the name "irc"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: epic
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-16 21:56 UTC by H. Peter Anvin
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-22 15:17:44 UTC


Attachments (Terms of Use)

Description H. Peter Anvin 2002-12-16 21:56:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021119

Description of problem:
IrcII was apparently omitted from RedHat Linux some time between 7.2 and 7.3. 
This is extremely unfortunate, since IrcII is very much the standard (reference)
IRC client, and that a lot of programs use it as an IRC "engine", since it is
possible to drive it from stdin/stdout.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to run /usr/bin/irc


Actual Results:  No such command

Expected Results:  Start IrcII


Additional info:

Comment 1 James Manning 2002-12-17 03:09:33 UTC
http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/release-notes/x86/

<blockquote>
The ircii package has been replaced with the epic package. epic is mostly
compatible with ircii scripts and includes more features than ircii.
</blockquote>

Comment 2 H. Peter Anvin 2002-12-23 21:46:11 UTC
If so, please consider this bug a bug in the epic package:

Need symlink /usr/bin/irc -> /usr/bin/epic

There are lots of scripts and programs that expect to be able to run "irc" and
have an ircii-compatible command line.



Note You need to log in before you can comment on or make changes to this bug.