Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79770 - fdisk 'w' command very slow
Summary: fdisk 'w' command very slow
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-16 19:58 UTC by David Balažic
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-13 21:58:11 UTC


Attachments (Terms of Use)

Description David Balažic 2002-12-16 19:58:10 UTC
Description of problem:

Write&exit command ( 'w' ) in fdisk takes 6 to 8 seconds.
Can we have a quick one ?
I think the slowness is caused by some sleep() and  sync() calls and 
REREAD_PARTITION ioctls.

If this is required for bug^Wbackward compatibility, can we have a new
"quick-write&exit" command that does exactly that ?

Comment 1 Elliot Lee 2003-01-13 21:58:11 UTC
To get a quick-write&exit command, the best thing to do would be to talk to the upstream 
maintainer at util-linux@math.uio.no


Note You need to log in before you can comment on or make changes to this bug.