Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79696 - pppd configured with on-boot and demand hangs in init
Summary: pppd configured with on-boot and demand hangs in init
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-15 13:46 UTC by George Collins
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-16 16:14:49 UTC


Attachments (Terms of Use)

Description George Collins 2002-12-15 13:46:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Init hangs when starting ppp device when both on-boot and demand are specified.
Assuming that it's hanging waiting for something to "demand" that it dial (which
can't happen until after the subsequent init scripts run). We need to be able to
bring up the interface on boot and have it dial on demand as necessary once the
system is up. Diableing the on-boot option works, but requires that the
interface be brought up manually after each boot. We need to be able to support
unattended reboots.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure dialup ppp for on-boot and demand dailing
2.Boot the system
3.
    

Actual Results:  init hangs at the starting interface pppN message

Expected Results:  Init shouldn't hang. Interface should come up on demand,
after booting.

Additional info:

Comment 1 Thomas Woerner 2004-08-16 16:14:49 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.