Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79691 - procmail dumps core
Summary: procmail dumps core
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procmail
Version: 9
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-15 08:10 UTC by Binand Sethumadhavan
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-06-23 04:03:55 UTC


Attachments (Terms of Use)

Description Binand Sethumadhavan 2002-12-15 08:10:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
when a signal is received, procmail dumps core.

This happens for I think all fatal signals procmail handles.

I tested with SIGINT, SIGTERM and SIGHUP. Procmail dumped core on all three 
occassions.

Typical output when I send a signal from another terminal to a running 
procmail:

binand@binand[~]:(11) procmail
procmail: Terminating prematurely
Segmentation fault (core dumped)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run procmail from command line (with or without an rc file)
2. press control-C for SIGINT
3. procmail will dump core, with the above output
    

Actual Results:  lots of core.$$ files in my home directory :)

Expected Results:  procmail should have performed a clean shutdown.

Additional info:

Comment 1 Jens Petersen 2003-08-10 02:25:11 UTC
Reproduced.

Sent a mail to the maintainer for feedback.

Comment 2 Jens Petersen 2004-01-06 08:00:00 UTC
This seems to be fixed when Debian's procmail_3.22-8.diff
is applied.

I'm adding that patch to procmail-3.22-12.


Note You need to log in before you can comment on or make changes to this bug.