Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79677 - No Carrier error causes loop attempting redial multiple times per second.
Summary: No Carrier error causes loop attempting redial multiple times per second.
Keywords:
Status: CLOSED DUPLICATE of bug 53432
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wvdial
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-14 22:45 UTC by Christopher Johnson
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:20 UTC


Attachments (Terms of Use)

Description Christopher Johnson 2002-12-14 22:45:05 UTC
Description of problem:
When wvdial is the dialler for a ppp interface in DEMAND mode, and for some
reason it gets a "NO CARRIER" error, it redials immediately but allows no time
for the call to go through.  This looping occurs multiple times per second until
the process is killed. It appears the failure condition or a timer for failure
to get carrier is not getting reset when redialling. 

Version-Release number of selected component (if applicable):
wvdial-1.53-7

How reproducible:
always

Steps to Reproduce:
1.Configure a ppp interface in DEMAND mode with WVDIALSECT=someconnection
2.During dialling disconnect the phone line, pause, reconnect to cause
connection failure.

    
Actual results:
wvdial loops, not waiting even for echo of the dialled number before declaring
NO CARRIER.

Expected results:
Redial attempt that allows time for call to go through and carrier to be
established.

Additional info:
I changed to a chat script which does not have this problem.  Perhaps chat
should be the default?

Comment 1 Christopher Johnson 2002-12-14 22:47:35 UTC
Syslog excerpt for the problem (I changed the phone number to avoid someone
annoying my ISP):
Dec  8 17:36:55 freedom pppd[8830]: Starting link
Dec  8 17:36:56 freedom wvdial[20795]: WvDial: Internet dialer version 1.53
Dec  8 17:36:56 freedom wvdial[20795]: Initializing modem.
Dec  8 17:36:56 freedom wvdial[20795]: Sending: ATZ
Dec  8 17:36:56 freedom wvdial[20795]: ATZ
Dec  8 17:36:56 freedom wvdial[20795]: OK
Dec  8 17:36:56 freedom wvdial[20795]: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Dec  8 17:36:56 freedom wvdial[20795]: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Dec  8 17:36:56 freedom wvdial[20795]: OK
Dec  8 17:36:56 freedom wvdial[20795]: Modem initialized.
Dec  8 17:36:56 freedom wvdial[20795]: Sending: ATDT1-999-999-9999
Dec  8 17:36:56 freedom wvdial[20795]: Waiting for carrier.
Dec  8 17:36:57 freedom wvdial[20795]: ATDT1-999-999-9999
Dec  8 17:37:57 freedom wvdial[20795]: Timed out while dialing.  Trying again.
Dec  8 17:37:57 freedom wvdial[20795]: Sending: ATDT1-999-999-9999
Dec  8 17:37:57 freedom wvdial[20795]: Waiting for carrier.
Dec  8 17:37:57 freedom wvdial[20795]: NO CARRIER
Dec  8 17:37:57 freedom wvdial[20795]: ATDT1-999-999-9999
Dec  8 17:37:57 freedom wvdial[20795]: No Carrier!  Trying again.
Dec  8 17:37:58 freedom wvdial[20795]: Sending: ATDT1-999-999-9999
Dec  8 17:37:58 freedom wvdial[20795]: Waiting for carrier.
Dec  8 17:37:58 freedom wvdial[20795]: NO CARRIER
Dec  8 17:37:58 freedom wvdial[20795]: ATDT1-999-999-9999
Dec  8 17:37:58 freedom wvdial[20795]: No Carrier!  Trying again.
Dec  8 17:37:58 freedom wvdial[20795]: Sending: ATDT1-999-999-9999
Dec  8 17:37:58 freedom wvdial[20795]: Waiting for carrier.
Dec  8 17:37:58 freedom wvdial[20795]: NO CARRIER
Dec  8 17:37:58 freedom wvdial[20795]: ATDT1-999-999-9999
Dec  8 17:37:58 freedom wvdial[20795]: No Carrier!  Trying again.


Comment 2 Harald Hoyer 2004-09-21 14:46:30 UTC

*** This bug has been marked as a duplicate of 53432 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:20 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.