Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79662 - grip takes down the kernel
Summary: grip takes down the kernel
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grip
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-14 19:03 UTC by Michael A. Peters
Modified: 2014-03-17 02:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-16 10:27:01 UTC


Attachments (Terms of Use)
rpm -qa > rpm.txt; gzip rpm.txt (deleted)
2002-12-14 19:07 UTC, Michael A. Peters
no flags Details

Description Michael A. Peters 2002-12-14 19:03:07 UTC
Description of problem:
If using grip to rip and encode a CD (oggenc) it will sometimes completely crash
the system. This seems to happen most often after the last track has been ripped.

It should be noted that oggenc when run manually sometimes segfaults on me.
Maybe it is oggenc that is to blame - I'll install lame and do mp3 to test.

Version-Release number of selected component (if applicable):
Whatever came on rh8

How reproducible:
Doesn't do it every CD, but about every other.
This machine has two cdrom drives - and it does it with both, so it unlikely is
a cdrom problem.
It seems to have a high frequency of freezing when I have not been using the
machine but it is ripping, and I come back and move the mouse - but sometimes it
happens if I don't or if I am using while ripping.

Steps to Reproduce:
1. insert cd and launch grip
2. select all tracks and tell her to rip and encode
3. Wait.
    
Actual results:
System crashes. Not pingable, NAT dies. Really ugly

Expected results:
I should have a crash free system and some groovy .ogg files.

Additional info:

Comment 1 Michael A. Peters 2002-12-14 19:07:35 UTC
Created attachment 88724 [details]
rpm -qa > rpm.txt; gzip rpm.txt

Comment 2 Michael A. Peters 2002-12-16 10:27:01 UTC
Close this bug.
My CPU died today and I suspect the _real_ problem was a faulty cpu.

There was a src.rpm I had that built fine last week - I added a few minor
patches and tried to build it and it wouldn't build but spit out compiler bug
errors etc.

Well - I put the HD in another box (also VIA athlon - same MHz etc.) and the
spec file compiled just fine and *so far* grip and oggenc have been flawless (no
crashes/segfaults)

So I suspect the crashes I was experiencing was due to a faulty CPU.

Oh well - got a XP 2200 and a new board coming :p


Note You need to log in before you can comment on or make changes to this bug.