Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79652 - Fatal Python error: could not import bonobo.ui
Summary: Fatal Python error: could not import bonobo.ui
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-python2
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
: 80190 80528 80610 80633 82496 82572 83807 (view as bug list)
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2002-12-14 16:08 UTC by Tim Waugh
Modified: 2007-04-18 16:49 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-07 16:19:24 UTC


Attachments (Terms of Use)
tail of strace redhat-config-printer (deleted)
2002-12-24 17:54 UTC, sean
no flags Details

Description Tim Waugh 2002-12-14 16:08:58 UTC
Description of problem:
Applet won't start.

Version-Release number of selected component (if applicable):
rhn-applet-2.0.6-1
bonobo-1.0.22-1

How reproducible:
100%

Steps to Reproduce:
1. rhn-applet-gui

Comment 1 Tim Waugh 2002-12-18 10:52:37 UTC
Changed component.  The files moved around in gnome-python2-bonobo, and python
can no longer find them.

Comment 2 Tim Waugh 2002-12-18 12:20:24 UTC
Okay, this seems to be caused by a messy upgrade.  Python is finding the files
in /usr/lib/python2.2/site-packages/bonobo, which is no longer owned by any
package, and so misses the files in
/usr/lib/python2.2/site-packages/gtk-2.0/bonobo altogether.

Perhaps we need
(a) to own the directory
(b) a preun to clean up .pyc/.pyo files in it
(c) a way to fix the fact that we didn't do this before.

Comment 3 Tim Waugh 2002-12-22 00:27:37 UTC
*** Bug 80190 has been marked as a duplicate of this bug. ***

Comment 4 sean 2002-12-24 17:54:35 UTC
Created attachment 88891 [details]
tail  of strace redhat-config-printer

Comment 5 sean 2002-12-24 18:24:37 UTC
rh-config-printer-0.6.25-1 still fails. See the attachment for tail of the
strace. It looks like it's looking for __builtin*, which don't exist anyplace on
my machine.

bonobo-1.0.22-1
bonobo-activation-2.1.1-1
bonobo-activation-devel-2.1.1-1
bonobo-conf-0.16-3
bonobo-conf-devel-0.16-3
bonobo-devel-1.0.22-1
gnome-python2-bonobo-1.99.13-2
libbonobo-2.1.0-1
libbonobo-devel-2.1.0-1
libbonoboui-2.1.1-1
libbonoboui-devel-2.1.1-1

Comment 6 Tim Waugh 2002-12-24 19:43:50 UTC
It's not a redhat-config-printer bug, but a gnome-python2 bug.  The work-around
for the time being is to:

rm -rf /usr/lib/python2.2/site-packages/bonobo


Comment 7 sean 2002-12-24 20:45:09 UTC
Thanks for the help. It worksforme.

jay

Comment 8 Tim Waugh 2002-12-28 12:09:03 UTC
*** Bug 80528 has been marked as a duplicate of this bug. ***

Comment 9 Bill Nottingham 2003-01-01 05:35:10 UTC
*** Bug 80610 has been marked as a duplicate of this bug. ***

Comment 10 Bill Nottingham 2003-01-01 05:52:26 UTC
*** Bug 80633 has been marked as a duplicate of this bug. ***

Comment 11 Bill Nottingham 2003-01-24 01:49:42 UTC
*** Bug 82572 has been marked as a duplicate of this bug. ***

Comment 12 Bill Nottingham 2003-01-24 01:49:56 UTC
*** Bug 82496 has been marked as a duplicate of this bug. ***

Comment 13 Matt Wilson 2003-02-06 21:32:12 UTC
Adding:

%triggerun bonobo -- gnome-python2-bonobo < 1.99.14-5
rm -f /usr/lib/python2.2/site-packages/bonobo/__init__.{pyc,pyo}


Comment 14 Jay Turner 2003-02-07 16:19:24 UTC
Fix confirmed with gnome-python2-bonobo-1.99.14-5.

Comment 15 Bill Nottingham 2003-02-10 22:20:35 UTC
*** Bug 83807 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.