Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79641 - bad source code
Summary: bad source code
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: isdn4k-utils
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-14 10:44 UTC by d.binderman
Modified: 2015-01-08 00:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 19:38:34 UTC


Attachments (Terms of Use)

Description d.binderman 2002-12-14 10:44:56 UTC
Description of problem:

Hello there,

I just tried to compile package isdn4k-utils-3.1-58 from Redhat 8.0.

Here are some of the compiler messages.

isdnlog/processor.c:3500: warning: `chan' might be used uninitialized in this function
tools/zone.c:534: warning: `ito' might be used uninitialized in this function
isdnlog/asn1_address.c:204: warning: `privateTypeOfNumber' might be used uninitialized in this function
isdnrep/isdnrep.c:2596: warning: `RetCode' might be used uninitialized in this function
isdnrep/isdnbill.c:877: warning: `dur' might be used uninitialized in this function
icnctrl.c:226: warning: operation on `cmd' may be undefined
avmcapictrl.c:368: warning: operation on `cmd' may be undefined
loopctrl.c:178: warning: operation on `cmd' may be undefined

Here is a patch which shuts up the compiler.

*** ./avmb1/avmcapictrl.c.old	2002-11-27 14:31:30.000000000 +0000
--- ./avmb1/avmcapictrl.c	2002-11-27 14:31:46.000000000 +0000
***************
*** 365,371 ****
  	char *spid2 = 0;
  
  	cmd = strrchr(argv[0], '/');
! 	cmd = (cmd == NULL) ? argv[0] : ++cmd;
  	if (argc > 1) {
  		arg_ofs = 1;
  	} else
--- 365,371 ----
  	char *spid2 = 0;
  
  	cmd = strrchr(argv[0], '/');
! 	cmd = (cmd == NULL) ? argv[0] : (cmd + 1);
  	if (argc > 1) {
  		arg_ofs = 1;
  	} else
*** ./icn/icnctrl.c.old	2002-11-27 14:30:43.000000000 +0000
--- ./icn/icnctrl.c	2002-11-27 14:31:10.000000000 +0000
***************
*** 223,229 ****
  	icn_cdef newcard;
  
  	cmd = strrchr(argv[0], '/');
! 	cmd = (cmd == NULL) ? argv[0] : ++cmd;
  	if (argc > 1) {
  		if (!strcmp(argv[1], "-d")) {
  			strcpy(ioctl_s.drvid, argv[2]);
--- 223,229 ----
  	icn_cdef newcard;
  
  	cmd = strrchr(argv[0], '/');
! 	cmd = (cmd == NULL) ? argv[0] : (cmd + 1);
  	if (argc > 1) {
  		if (!strcmp(argv[1], "-d")) {
  			strcpy(ioctl_s.drvid, argv[2]);
*** ./isdnlog/isdnlog/asn1_address.c.old	2002-11-27 14:28:31.000000000 +0000
--- ./isdnlog/isdnlog/asn1_address.c	2002-11-27 14:28:42.000000000 +0000
***************
*** 201,207 ****
  
  int ParsePrivatePartyNumber(struct Aoc *chanp, u_char *p, u_char *end, char *str)
  {
! 	int privateTypeOfNumber;
  	char numberDigits[20];
  	INIT;
  
--- 201,207 ----
  
  int ParsePrivatePartyNumber(struct Aoc *chanp, u_char *p, u_char *end, char *str)
  {
! 	int privateTypeOfNumber = 0;
  	char numberDigits[20];
  	INIT;
  
*** ./isdnlog/isdnlog/processor.c.old	2002-11-27 14:27:28.000000000 +0000
--- ./isdnlog/isdnlog/processor.c	2002-11-27 14:27:41.000000000 +0000
***************
*** 3497,3503 ****
       isdn_net_ioctl_phone netdvX_phone;
  #endif
    }	   phone;
!   auto	   int rc, chan, l1, l2, lmin, lmax, ldiv, match;
  
    if ((iflst = fopen("/proc/net/dev", "r")) == NULL)
      return(-1);
--- 3497,3503 ----
       isdn_net_ioctl_phone netdvX_phone;
  #endif
    }	   phone;
!   auto	   int rc, chan = 0, l1, l2, lmin, lmax, ldiv, match;
  
    if ((iflst = fopen("/proc/net/dev", "r")) == NULL)
      return(-1);
*** ./isdnlog/isdnrep/isdnbill.c.old	2002-11-27 14:30:11.000000000 +0000
--- ./isdnlog/isdnrep/isdnbill.c	2002-11-27 14:30:22.000000000 +0000
***************
*** 874,880 ****
  #endif
    auto     char     s[BUFSIZ], sx[BUFSIZ];
    auto     int      i, l, col, day, lday = UNKNOWN, month, lmonth = UNKNOWN;
!   auto     double   dur;
    auto     char    *version;
    auto     char    *myname = basename(argv[0]);
    auto     int      opt, go, s0, indent;
--- 874,880 ----
  #endif
    auto     char     s[BUFSIZ], sx[BUFSIZ];
    auto     int      i, l, col, day, lday = UNKNOWN, month, lmonth = UNKNOWN;
!   auto     double   dur = 0.0;
    auto     char    *version;
    auto     char    *myname = basename(argv[0]);
    auto     int      opt, go, s0, indent;
*** ./isdnlog/isdnrep/isdnrep.c.old	2002-11-27 14:29:13.000000000 +0000
--- ./isdnlog/isdnrep/isdnrep.c	2002-11-27 14:29:50.000000000 +0000
***************
*** 2593,2599 ****
  {
    static char String[256];
    one_call *tmp_call;
!   int RetCode;
  
  
    if (bill)
--- 2593,2599 ----
  {
    static char String[256];
    one_call *tmp_call;
!   int RetCode = 0;
  
  
    if (bill)
*** ./isdnlog/tools/zone.c.old	2002-11-27 14:28:01.000000000 +0000
--- ./isdnlog/tools/zone.c	2002-11-27 14:28:11.000000000 +0000
***************
*** 531,537 ****
  			char *p = value.dptr;
  			char to[10];
  			US count;
! 			int ito;
  			unsigned char z=0;
  			if (sthp->cc) /* if areacodes */
  				/* here is since 1.00 a zero-terminated strring */
--- 531,537 ----
  			char *p = value.dptr;
  			char to[10];
  			US count;
! 			int ito = 0;
  			unsigned char z=0;
  			if (sthp->cc) /* if areacodes */
  				/* here is since 1.00 a zero-terminated strring */
*** ./loop/loopctrl.c.old	2002-11-27 14:32:08.000000000 +0000
--- ./loop/loopctrl.c	2002-11-27 14:32:23.000000000 +0000
***************
*** 175,181 ****
  	isdnloop_sdef startparm;
  
  	cmd = strrchr(argv[0], '/');
! 	cmd = (cmd == NULL) ? argv[0] : ++cmd;
  	if (argc > 1) {
  		if (!strcmp(argv[1], "-d")) {
  			strcpy(ioctl_s.drvid, argv[2]);
--- 175,181 ----
  	isdnloop_sdef startparm;
  
  	cmd = strrchr(argv[0], '/');
! 	cmd = (cmd == NULL) ? argv[0] : (cmd + 1);
  	if (argc > 1) {
  		if (!strcmp(argv[1], "-d")) {
  			strcpy(ioctl_s.drvid, argv[2]);


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Ngo Than 2003-08-11 19:38:34 UTC
It's fixed in 3.1-76. thanks for your patch file.


Note You need to log in before you can comment on or make changes to this bug.