Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79634 - faulty source code ?
Summary: faulty source code ?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dvdrtools
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-14 10:25 UTC by d.binderman
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-25 18:42:18 UTC


Attachments (Terms of Use)

Description d.binderman 2002-12-14 10:25:44 UTC
Description of problem:

Hello there,

I just tried to compile package dvdrtools-0.1.2-4 from Redhat 8.0.

Here are some of the compiler messages.

scsitransp.c:1290: warning: unknown conversion type character `r' in format
comerr.c:191: warning: unknown conversion type character `r' in format
comerr.c:199: warning: unknown conversion type character `r' in format
error.c:46: warning: unknown conversion type character `r' in format
serrmsg.c:106: warning: unknown conversion type character `r' in format
serrmsg.c:115: warning: unknown conversion type character `r' in format
cdda2wav.c:573: warning: unknown conversion type character `r' in format
cdda2wav.c:599: warning: unknown conversion type character `r' in format
io.c:205: warning: unknown conversion type character `r' in format

I don't know what the %r specifier is, not does the compiler.
I don't have a fix for this problem.

There were some other compiler messages

drv_mmc.c:1008: warning: `ret' might be used uninitialized in this function
rock.c:597: warning: `blocksize' might be used uninitialized in this function
rock.c:598: warning: `headersize' might be used uninitialized in this function


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Mike A. Harris 2003-01-24 16:35:36 UTC
I've just successfully recompiled this package on a fresh Red Hat Linux 8.0
install, by taking the source code RPM package and doing:

rpm --rebuild <packagename>

It built successfully, and installed.  I can only assume that you are not
using the Red Hat supplied compiler, and are using some third party compiler,
or you have modified the package(s) in some way that is incompatible.

At any rate, this works for me.

Comment 2 d.binderman 2003-01-25 11:53:08 UTC
This is another case where I appear to have forgotten
to add that compiler flags "-g -O2 -Wall" to get the compiler
to complain.

That'll teach me to report a dozen bugs at the same time.



Comment 3 Mike A. Harris 2003-01-25 18:42:18 UTC
The software compiles, does so properly, and when it is done compiling,
it works, and works properly.  The packages we ship are properly functional.

Red Hat does not offer technical support via bugzilla, nor do we offer
technical support to people recompiling the software we ship.  If you
have problems recompiling something, or questions about compiler warnings
that you receive recompiling something, the proper place to ask these
questions is on a mailing list of some kind.  The best suggestion would
be to get in contact with the upstream developers of the software you
are trying to compile, and discuss the issue with their source code
directly with them.

Do not file technical support requests in bugzilla.

Closing NOTABUG.




Note You need to log in before you can comment on or make changes to this bug.