Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79627 - RFE: Improvement to optional USB mouse (Laptops)
Summary: RFE: Improvement to optional USB mouse (Laptops)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kudzu
Version: phoebe
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
: 71970 (view as bug list)
Depends On: 80359
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2002-12-14 05:19 UTC by Warren Togami
Modified: 2014-03-17 02:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 03:47:59 UTC


Attachments (Terms of Use)

Description Warren Togami 2002-12-14 05:19:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Red Hat 8.0 introduced an extra USB mouse that is configured by default in
XF86Config.  This has been very convenient for laptop users with PS/2 touchpads
and hotpluggable USB mouse.  This dual mouse operation works great with only one
minor exception.

During system bootup, kudzu sees that the USB mouse has been added or removed
and attempts to reconfigure the mouse, running text mode  "mouseconfig".  This
can be confusing to less experienced users since mouse configuration does not
need to change.

I propose that minor modifications be made to kudzu so it will know when to
ignore changes in the optional USB mouse.  Perhaps kudzu could check a flag set
by redhat-config-mouse (or the Anaconda equivalent) in /etc/sysconfig.

How reproducible:
Always

Steps to Reproduce:
1. Setup laptop with PS/2 mouse, optional USB mouse is configured.
2. Plug or unplug USB mouse before kudzu during bootup.

Actual Results:  
Kudzu asks you to reconfigure the mouse.  Potential end user confusion.

Expected Results:  
It should ignore the adding/removing the USB mouse since it is optional and
hotpluggable.

Comment 1 George Karabin 2003-01-03 23:12:27 UTC
Another equally annoying problem is that Kudzu will run at boot when alternating
a laptop between docking staticn connect and disconnect. On my Dell Latitude
C610, it will step the user through USB hub detection/removal, ethernet
detection/removal, etc.

The same proposed solution would be nice for these sorts of peripherals as well.


Comment 2 Warren Togami 2003-02-05 08:49:51 UTC
Recently introduced in Rawhide was some behavior in either kudzu or
redhat-config-mouse that made the situation a bit worse.  Now when booting,
kudzu detects the new USB mouse, if you choose "Configure" it configures without
going into the text-mode mouse configuration tool.  Getting rid of the mouse
configuration tool was good, however it automatically configured the USB mouse
as if it were the only mouse, rendering the PS/2 touchpad disabled.

I'm not entirely sure if this is in kudzu or redhat-config-mouse, which
component should I file this under?

Comment 3 Bill Nottingham 2003-02-05 17:49:16 UTC
kudzu is now calling redhat-config-mouse with the same arguments that it used to
call the old mouseconfig. We might want to check to see how it's handling this.

Comment 4 Bill Nottingham 2003-02-20 03:47:59 UTC
Fixed in 0.99.97; it now does not configure newly found USB mice, as they're
always configured.

Comment 5 George Karabin 2003-02-20 04:40:14 UTC
Should I file a separate RFE for comment #1?


Comment 6 Bill Nottingham 2003-02-20 05:02:28 UTC
There's already a bug on handling docking stations. Not sure what a good way to
do it is, though.

Comment 7 Bill Nottingham 2003-03-11 16:25:56 UTC
*** Bug 71970 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.