Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79622 - Using GTK 2.1.4 with GNOME2.0 crashes apps
Summary: Using GTK 2.1.4 with GNOME2.0 crashes apps
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: libgnomeui
Version: 1.0
Hardware: athlon
OS: Linux
low
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-14 03:02 UTC by Alan Cramer
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-14 15:29:00 UTC


Attachments (Terms of Use)

Description Alan Cramer 2002-12-14 03:02:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
When I use certain GNOME 2.0 apps such as terminal, I get Seg Faults as a result
when using GTK 2.1.4.  libgnomeui needs to have an rpm made for the stable
series (As I like to mix and match stable with unstable).

I am aware that a new release of libgnomeui will come out with the release of
GTK 2.2, but currently I don't wish to use GNOME 2.1 only GNOME 2.0

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install GTK 2.1.4 RPM
2. Open gnome-terminal
    

Actual Results:  Application Seg Faults with

(gnome-terminal:23344): GLib-GObject-WARNING **: cannot create instance of
abstract (non-instantiatable) type `GtkWidget'


Additional info:

Comment 1 Havoc Pennington 2002-12-14 15:29:00 UTC
rawhide is intended to be used as a set, we don't support all possible
combinations. Well, we don't support rawhide at all, it's just a devel 
snapshot, but it's intended to be tested as a set. ;-)

If you want to patch an old libgnomeui, look for a function call to 
gtk_type_new() or g_object_new() that takes GTK_TYPE_WIDGET as an argument, and 
change GTK_TYPE_WIDGET to say GTK_TYPE_INVISIBLE instead.

Comment 2 Alan Cramer 2002-12-17 05:16:10 UTC
I know this is closed, but thanks for you help.  My system is working again
fully and I can use all gnome software,


Note You need to log in before you can comment on or make changes to this bug.