Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7961 - current dhcpcd has problems
Summary: current dhcpcd has problems
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: dhcpcd
Version: 1.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
: 4031 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-23 06:11 UTC by michal
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-07-17 00:06:02 UTC


Attachments (Terms of Use)
Source rpm for a fixed version of dhcpcd daemon (deleted)
1999-12-23 06:12 UTC, michal
no flags Details
one more try to send old dhcpcd source rpm (deleted)
2001-07-17 00:05 UTC, Michal Jaegermann
no flags Details

Description michal 1999-12-23 06:11:14 UTC
A version of dhcpcd daemon, 1.3.17-pl5, included in the current
rawhide, and also on 6.1 distribution, suffers from various problems
and has a code which causes multiple "unaligned access" problems
on Alpha (probably also on other architectures as well but Alpha
reports it :-).

Included with this report is src.rpm archive based on 1.3.18-pl3
which is much more portable between architectures.  An extra patch
resolves one remaining "unaligned access" spot.  This version of
the daemon works as shown by the fact that it maintains a connection
which I utilize to send this report.

Michal Jaegermann, michal@harddata.com

Comment 1 michal 1999-12-23 06:12:59 UTC
Created attachment 43 [details]
Source rpm for a fixed version of dhcpcd daemon

Comment 2 Bill Nottingham 2000-02-05 06:52:59 UTC
*** Bug 4031 has been marked as a duplicate of this bug. ***

Comment 3 Erik Troan 2000-02-23 20:41:59 UTC
We suggest using pump for this instead of dhcpcd.

Comment 4 Elliot Lee 2001-07-16 23:18:19 UTC
Now that rawhide has dhcpcd back in it, I'd very much like to see the patch, the
problem being that the attached file is not a valid .rpm.

Comment 5 Michal Jaegermann 2001-07-17 00:04:36 UTC
Indeed. Something ate that attachment badly.  I still happen to have it around
but with newer versions of dhcpcd possibly some other tweaks are needed.
For the sake of a historical completness (binaries still work fine) let's
try again.

Comment 6 Michal Jaegermann 2001-07-17 00:05:58 UTC
Created attachment 23747 [details]
one more try to send old dhcpcd source rpm

Comment 7 Elliot Lee 2001-07-17 00:19:38 UTC
Thanks, fix is in dhcpcd-1.3.18pl8-13


Note You need to log in before you can comment on or make changes to this bug.