Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79557 - french version of df output the heading line with a spurious line break
Summary: french version of df output the heading line with a spurious line break
Keywords:
Status: CLOSED DUPLICATE of bug 76341
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xcdroast
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-13 11:05 UTC by Need Real Name
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:19 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-12-13 11:05:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; fr-FR; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
By running xcdroast on a fresh RH80 with french language, it fails
immediately with the message df -k bad output...

This is due to the output of df as follows:

Systeme de 
Fichiers Tail. Util. Disp. Uti. Monte sur
/dev/hda3 .....
/dev/hda( ....

Note the line break between "Systeme de"  and "Fichiers"

FIX 1:
I have to run xcdroast in english using the following script:

#!/bin/sh
LANG=en_US
export $LANG
xcdroast

FIX 2:
I edited binary file /usr/share/locale/fr/LC_MESSAGES/fileutils.mo
and replaced the line break at offset 111e6 by a space. 
Now I can run xcdroast in french ;-)
 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set LANG to fr_FR 
2.restart
3.run xcdroast
    

Additional info:

Comment 1 Need Real Name 2002-12-13 11:06:55 UTC
I had to remove all "accentuated" french characters from the description, since
I got a Software error (invalid unicode characters ...) at globals.pl when 
pressing the button "Commit".

Comment 2 Tim Waugh 2002-12-13 11:13:10 UTC
This xcdroast bug is fixed in rawhide.

*** This bug has been marked as a duplicate of 76341 ***

Comment 3 Need Real Name 2002-12-20 10:04:05 UTC
Although I am glad you marked this one as fixed, I am quite surprisedabout the fix you propose on rawhide.   You patched xcdroast ... but the culprit is the french translationprovided for the df command in fileutils.mo ... so additionnal bugs may appear in the future with other utilities relying on the output of df .  I would suggest to patch fileutils package once for good instead ofproviding fixes to utilities that seems otherwise good.Season greetings.

Comment 4 Tim Waugh 2002-12-20 10:29:24 UTC
You are incorrect; any utility expecting a particular format of output must
specify a locale first.  That's what xcdroast now does ('LANG=C df'.

Comment 5 Need Real Name 2002-12-20 13:02:08 UTC
Ok. You know best...

But still I do not understand with the french df output two lines
of headers instead of one:
French df:

Systeme de
Fichiers
/dev/hda1/ ..........

English df:

Filesystem
/dev/hda1/....

Season greetings.



Comment 6 Red Hat Bugzilla 2006-02-21 18:50:19 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.