Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79550 - At the first time the Internet configuration wizard crash
Summary: At the first time the Internet configuration wizard crash
Keywords:
Status: CLOSED DUPLICATE of bug 76446
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-13 10:51 UTC by Michele Milesi
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:19 UTC


Attachments (Terms of Use)

Description Michele Milesi 2002-12-13 10:51:36 UTC
Description of problem:
When I start "Internet configuration wizard" the application crash.

Version-Release number of selected component (if applicable):


How reproducible:
It's the first time that the wizard starts

Steps to Reproduce:
1. Launch the wizard
    
Actual results:
Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 473, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/NewInterfaceDialog.py", line 82, in __init__
    iface = iface_creator (self.toplevel, do_save = None, druid = self.druid)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetInterface.py", line 101, in __init__
    self.hwDruid = ethernetHardware(self.toplevel)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py", line 64, in __init__
    self.setup()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py", line 118, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Local variables in innermost frame:
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84d6cc8>
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA wireless', 'SMC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco PCMCIA wireless (alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-i365 wireless', 'Intel EtherExpress/1000', 'PCI NE2000 clones', 'MiCom-Interlan NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 ethernet', 'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM MyriNET SBUS', '3Com EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 900/7016CI', 'Cabletron E2100', 'NE1000, NE2000, and compatible', 'Intel EtherExpress Pro 100B', 'Allied Telesis AT1700', 'Greenwigh GIrBIL IrDA', 'Older DEC 21040, most 21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 16i/32 EISA', '3Com 3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun BigMac', 'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel Communications Model 3200', 'Aironet 4500 PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General Instruments SB1000']
self: <netconfpkg.gui.EthernetHardwareDruid.ethernetHardware instance at 853e740>
i: defxx


Additional info:
Installed ximian gnome

Comment 1 Harald Hoyer 2002-12-16 09:43:50 UTC

*** This bug has been marked as a duplicate of 76446 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:19 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.