Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79548 - *.la files missing in devel packages
Summary: *.la files missing in devel packages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ORBit
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-13 10:30 UTC by Joerg Lehrke
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-13 13:55:46 UTC


Attachments (Terms of Use)

Description Joerg Lehrke 2002-12-13 10:30:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021212

Description of problem:
To link programs against ORBit libraries using libtool you need the *.la files
within the devel package. These files are missing in many *-devel.%{arch}.rpm
files. Therefore I was not able to rebuild e.g. the galeon package on my machine.

Resulution: Add the *.la files to %files devel

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to rebuild the galeon RPM on a Red Hat8.0 machine.

    

Actual Results:  Failed with errors about the missing files.

Expected Results:  Success;-)

Additional info:

Pleas check all Gnome releated devel-RPMS for these files.

Comment 1 Havoc Pennington 2002-12-13 13:55:46 UTC
You don't need the .la files - we have dozens of packages linked to ORBit
without them. 

The idea is to use orbit-config (ORBit1) or pkg-config (ORBit2) to get the 
libs. 

We have a deliberate policy of excluding .la files from the gnome packages.

Comment 2 Joerg Lehrke 2002-12-13 14:13:47 UTC
This mentioned policy seems to be not implemented in a consistent way. I expect that a 
Red Hat release is self-consistent, so that you're able to recompile everything within 
the distribution itself. I could not recompile the galeon package on 8.0 because of the 
missing *.la files. I think this happens with other Gnome packets as well. 

Comment 3 Havoc Pennington 2002-12-13 16:07:00 UTC
You get an error message about "libfoo.la not found" right?

grep for "libfoo.la" in /usr/lib/*.la. Then "rpm -qf /usr/lib/whatever.la" 
for any .la files that contain a reference to libfoo.la. If you find 
whatever.la owned by a Red Hat official package, referring to nonexistent
libfoo.la, then that's a bug we should fix. If whatever.la isn't owned
by a package we shipped in 8.0, then it's a problem with wherever you got 
whatever.la.


Note You need to log in before you can comment on or make changes to this bug.