Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79540 - RHN Proxy channel dangles if no parent
Summary: RHN Proxy channel dangles if no parent
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: RHN Devel
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Matt Jamison
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-12 21:22 UTC by Todd Warner
Modified: 2005-10-31 22:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-17 16:00:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
Example of dangling rhn proxy channel (deleted)
2002-12-12 21:23 UTC, Todd Warner
no flags Details

Description Todd Warner 2002-12-12 21:22:17 UTC
Description of Problem:
E.g. if I have access to RHN Proxy Channel, but do not have advanced server, the
channel still displays (thought we licked this!).

See attached PNG

Comment 1 Todd Warner 2002-12-12 21:23:33 UTC
Created attachment 88684 [details]
Example of dangling rhn proxy channel

Comment 2 Chip Turner 2002-12-14 19:45:50 UTC
fixed, though this is a broken case.  we need to make a new entitlement for
proxy AS so that this doesn't happen.  it can happen now because you have no
access to the parent channel.

to reproduce:
make new account, grant rhn-proxy but NOT AS.

now renders as (no access to channel) for the parent and displays the child as
expected

Comment 3 Josef Komenda 2002-12-15 04:06:01 UTC
Will need help with this, as my granting abilities are messed up. (since going
to 8.0)



Comment 4 Bret McMillan 2002-12-16 23:29:24 UTC
I created the rh8_stapler (password:  pink4all) account on rhn.webqa.

Then granted it 2 slots to rhn-proxy family, and nothing else.  Initial glance
appears that the issue is now fixed.

Comment 5 Josef Komenda 2002-12-17 16:00:30 UTC
Looks good on QA - closing.


Note You need to log in before you can comment on or make changes to this bug.