Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79538 - section name globbing feature request
Summary: section name globbing feature request
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-12 21:14 UTC by Mike Snitzer
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-23 20:56:26 UTC


Attachments (Terms of Use)

Description Mike Snitzer 2002-12-12 21:14:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
I was just flirting with having mpich, mpich-gm, lam (all of which have the same
man page names) deposit their man pages with names like:
/usr/share/man/man1/mpirun.1mpich-1_2_4.gz .. but in order to make use of such a
section (man -S 1mpich-1_2_4 mpirun) I'd need section name globbing support;
turns out RedHat's man package doesn't support section globbing... SO I wrote a
spec file for debian's man-db and ported that to play nicely with RH.. so I got
myself section name globbing capability; but in the end I was left with a
non-standard man package that I'd have to maintain.

Section name globbing would be a useful feature; but I'll let others decide if
such a feature is worth the effort.  One thing is clear; RedHat's man lacks
modern features found in other distros (section name globbing is just one of
them =).

For now the man pages for the mpi libraries will reside in a non-standard MANPATH.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. from within the same $major_man_section (i.e. /usr/share/man/man1) create
some $test_manpage with a $variable section name; have the $test_manpage's
basename be named the same as an already existing manpage
2. try to access said $test_manpage with: man -S $variable $test_manpage
3. the $PAGER may or may not display the desired $test_manpage; it may just
display the manpage that is named similarly in the $major_man_section
	

Actual Results:  The same manpage is displayed everytime regardless of the
MANSECT env. variable or the use of -S flag. The reason for this RedHat's man
doesn't support searching for a specific variable length/named man section; the
most it'll support is GNU style: man 3x foo (which is /usr/share/man/man3/foo.3x.gz)

Expected Results:  Desired result would be to have man pull up the manpage
within the specified section in a deterministic way.  

Additional info:  I'm sure patches would be graciously accepted but I can't
dedicate time to this.

Comment 1 Eido Inoue 2003-01-02 16:42:03 UTC
So where's the patch?

Comment 2 Mike Snitzer 2003-01-02 18:47:59 UTC
Please see the "Additional Info" of the original feature request.  At one point,
the redhat man codebase was seemingly derived from the same codebase that debian
uses for man-db.  As for why a fork occured I have no idea; but I'd suggest
embracing Debian's man-db codebase that is being actively maintained.

Comment 3 Eido Inoue 2004-08-23 20:56:26 UTC
we have to keep the fork for now due to i18n and customer-driven
requests. i don't see a quick and easy way to put this in. the desired
behavior can be had with some iterative bash loop code around the man
request. not ideal or intuitive, granted, but a workaround nevertheless.


Note You need to log in before you can comment on or make changes to this bug.