Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79523 - Pan crashes when replying by e-mail
Summary: Pan crashes when replying by e-mail
Keywords:
Status: CLOSED DUPLICATE of bug 77989
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pan
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-12 18:23 UTC by Florin Andrei
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:18 UTC


Attachments (Terms of Use)
e-mail crash bug (deleted)
2002-12-13 19:01 UTC, Florin Andrei
no flags Details

Description Florin Andrei 2002-12-12 18:23:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Pan crashes when i reply by e-mail to any news article.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Click on a news article
2.Click on Post / Reply by Email
3.Write the reply
4.Send
	

Actual Results:  Pan crashes (but the message is sent ok)

Expected Results:  Pan should not crash

Additional info:

I'm using localhost:25 as a mailing server, running Postfix.
I noticed this bug long time ago, with RH 7.2 or 7.3 i think.

Comment 1 Michael Lee Yohe 2002-12-13 15:21:08 UTC
This is interesting.  You can help out by the following:

1) Open a terminal.
2) Run:

strace pan 1> pan_stdout.txt 2> pan_sterr.txt

3) Include both of the output text files to this bug so that we can see what
exactly is happened.

Also - have you been able to produce this using sendmail instead of postfix?

Comment 2 Florin Andrei 2002-12-13 18:59:27 UTC
I could test with sendmail, but i'd rather not tweak my MTA right now. :-)

But i ran the command you told me, and i'll attach the results soon.
The pan_stdout.txt file is empty, so i'll attach only pan_sterr.txt

Comment 3 Florin Andrei 2002-12-13 19:01:34 UTC
Created attachment 88695 [details]
e-mail crash bug

Here ya go. This is the result of running:

strace pan 1> pan_stdout.txt 2> pan_sterr.txt

I opened a newsgroup, replied to a message via e-mail. Then Pan crashed.
pan_stdout.txt is empty.

Comment 4 Jens Petersen 2002-12-17 06:10:43 UTC

*** This bug has been marked as a duplicate of 77989 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:50:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.