Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79505 - Cannot change user passwords
Summary: Cannot change user passwords
Keywords:
Status: CLOSED DUPLICATE of bug 70783
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-12 15:11 UTC by Joshua Crunk
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:18 UTC


Attachments (Terms of Use)

Description Joshua Crunk 2002-12-12 15:11:13 UTC
Description of Problem:  Same problem as reported in Bugzilla 70783, 73719, 
76414, 78064.  Cannot change user passwords with redhat-config-users-1.0.1-5.  
When I click OK to apply the change, NOTHING happens.  However, I CAN add or 
delete users with redhat-config-users.

Problem is, the solution on the above bug #s is to use redhat-config-users-1.1-
16 or redhat-config-users-1.1-9.  I cannot find either of these on 
rawhide.redhat.com.  The only version that I could find on rawhide was redhat-
config-users-1.1.1-4, which crashes on my system upon execution.

This problem seemed to arise on the Samba update to 2.2.7-1.7.3. (machine with 
bug is a Samba PDC). 


How Reproducible:  Every time


Steps to Reproduce:
1.Start redhat-config-users
2.Open the properties sheet for a user
3.Change the user's password
4.Click OK.
5.Properties sheet should close, but does NOT.


Actual Results:  Properties sheet does NOT close, and error messages are printed
in the shell window.

[root@linux73 root]# redhat-config-users
/usr/share/redhat-config-users/userWindow.py:73: DeprecationWarning: use 
GtkListStore/GtkTreeView
  self.loginShellCombo.list.select_item(self.shells.index(default))
/usr/share/redhat-config-users/userProperties.py:159: DeprecationWarning: use 
GtkListStore/GtkTreeView
  self.loginShellCombo.list.select_item(self.shells.index(shell))
/usr/share/redhat-config-users/userProperties.py:461: DeprecationWarning: use 
GtkListStore/GtkTreeView
  self.primaryGroupCombo.list.select_item(index)
Traceback (most recent call last):
  File "/usr/share/redhat-config-users/userProperties.py", line 257, in 
on_ok_button_clicked
    self.parent.ADMIN.setpassUser(self.userEnt, pw)
TypeError: function takes exactly 3 arguments (2 given)
[root@linux73 root]#


Expected Results:  Properties sheet should close, saving changes to user's 
password.

Comment 1 Brent Fox 2002-12-18 16:27:23 UTC

*** This bug has been marked as a duplicate of 70783 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:50:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.