Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79487 - EthernetHardwareDruid.py exception due to /boot/module-info defxx ethernet device description missing
Summary: EthernetHardwareDruid.py exception due to /boot/module-info defxx ethernet de...
Keywords:
Status: CLOSED DUPLICATE of bug 76446
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-12 11:00 UTC by Edward J. Huff
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-12 11:00:18 UTC


Attachments (Terms of Use)

Description Edward J. Huff 2002-12-12 11:00:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Exception in EthernetHardwareDruid.py due to missing description
of the defxx ethernet device in /boot/module-info.

[root@desk root]# diff -c /boot/module-info-2.4.18-17.7.x
/boot/module-info-2.4.18-18.7.x 
*** /boot/module-info-2.4.18-17.7.x	Mon Nov 11 21:04:46 2002
--- /boot/module-info-2.4.18-18.7.x	Wed Nov 13 19:35:02 2002
***************
*** 162,168 ****
  
  defxx
  	eth
- 	"EthernetHardwareDruid.py exception if this string is missing"
  
  depca
  	eth
--- 162,167 ----
[root@desk root]# locate EthernetHardwareDruid
/usr/share/redhat-config-network/netconfpkg/EthernetHardwareDruid.pyc
/usr/share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.glade
/usr/share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py
/usr/share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.pyc
[root@desk root]# rpm -qf
/usr/share/redhat-config-network/netconfpkg/EthernetHardwareDruid.pyc
file /usr/share/redhat-config-network/netconfpkg/EthernetHardwareDruid.pyc is
not owned by any package
[root@desk root]# rpm -qf
/usr/share/redhat-config-network/netconfpkg/gui/EthernetHardwareDruid.py
redhat-config-network-1.0.0-1
[root@desk root]# rpm -qf /boot/module-info-2.4.18-18.7.x
kernel-2.4.18-18.7.x
[root@desk root]# 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install everything (all packages...)
2.Install all latest packages from errata
3.Run "neat" and try to configure ethernet.

	

Actual Results:  An exception until I debugged it and edited /boot/module-info.


Expected Results:  I expected to see the list of ethernet devices.

Additional info:

Better fix is modify the EthernetHardwareDruid.py to handle the
exception when there is no description for an ethernet device type.

Comment 1 Harald Hoyer 2002-12-12 11:29:58 UTC

*** This bug has been marked as a duplicate of 76446 ***

Comment 2 Harald Hoyer 2002-12-12 11:30:38 UTC
third beta of erratum for 7.3/7.2/AS2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.3-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.3 version... Thx
and please test.


Note You need to log in before you can comment on or make changes to this bug.