Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79468 - Autorun + causes lockups with audio CDs in KDE
Summary: Autorun + causes lockups with audio CDs in KDE
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autorun
Version: 8.0
Hardware: i586
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-11 23:13 UTC by Roberto Scaramuzzi
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-29 10:07:37 UTC


Attachments (Terms of Use)

Description Roberto Scaramuzzi 2002-12-11 23:13:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Red Hat 8.0 uses autorun by default (through use of an Autorun item in
$HOME/.kde/Autostart.

This created problems for me when inserting audio CDs. The autorun binary
launches an unresponsive kscd (the window appears but does not respond to clicks
or get updated when covered by another window then uncovered). In addition the
system load went over 5 . Running top showed that autorun and kjournald were the
main processes that used up CPU time (which seems to suggest this has something
to do with ext3 also). The console showed many SCSI errors and resets.

I ended up having to restart my machine with the reset button (the console had
become completely unresponsive)

The problem disappeared after I removed the Autorun item from the Autostart folder

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start a KDE session with the default Redhat 8.0 setup
2.Insert an audio CD in the CDROM drive


Actual Results:  See above

Additional info:

I'm using a new machine with a generic CD/CD-RW drive.

More hardware details available upon request.
I tried with two different auido CDs, with the same result.

Comment 1 Harald Hoyer 2003-01-09 13:33:29 UTC
ouch... this is strange and the first report of this kind...

Comment 2 Harald Hoyer 2003-01-09 14:43:10 UTC
hmm, workx for me.. can you run autorun with the -v option from a terminal?
$ autorun -v



Comment 3 Harald Hoyer 2003-08-05 08:32:02 UTC
ping??? more info or close the bug please

Comment 4 Harald Hoyer 2004-01-29 10:07:37 UTC
closed, due to no response...


Note You need to log in before you can comment on or make changes to this bug.