Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 7945 - netconfig dumps core if hostname not found (with source fix!)
Summary: netconfig dumps core if hostname not found (with source fix!)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-22 09:50 UTC by Stephen J. Friedl
Modified: 2014-03-17 02:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-23 21:04:11 UTC


Attachments (Terms of Use)

Description Stephen J. Friedl 1999-12-22 09:50:33 UTC
pump-0.7.2 contains netconfig (the interactive network setup program),
and when it takes the machine's hostname to do a reverse DNS lookup,
it dumps core if the name is not found.

The problem is in "net.c" near line 464:

    int findHostAndDomain(...)
    {
       ....
    #ifdef __STANDALONE__
       he = gethostbyaddr( (char *)&dev->dev.ip, sizeof....);
       name = he->h_name; /* BUG BUG BUG */
    #else
       name = mygethostbyaddr(inet_ntoa(dev->dev.ip));
    #endif

The bug-marked line dereferences "he" even if it's a NULL, and this
causes a core dump. This line should instead be:

       name = he ? he->h_name : 0;

so that (a) we don't dereference "he" unless it's valid, and
(b) the "name" variable is always initialized with *something*.

Comment 1 Bill Nottingham 1999-12-22 16:51:59 UTC
Fixed in CVS. Will be fixed in next pump release.


Note You need to log in before you can comment on or make changes to this bug.