Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79427 - internal compiler error in print_rtl_and_abort, gcc3
Summary: internal compiler error in print_rtl_and_abort, gcc3
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-11 16:44 UTC by Dean Bandes
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-12-16 02:26:12 UTC


Attachments (Terms of Use)
problem description, command line, and preprocesser output (deleted)
2002-12-11 16:54 UTC, Dean Bandes
no flags Details

Description Dean Bandes 2002-12-11 16:44:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I get a compiler internal error in attempting to compile a file of which the 
preprocessed form will be attached. Please refer to the attachment for compiler 
command line, error message, and input.

Error is reported as

Internal compiler error in print_rtl_and_abort

Error depends on the program having declared a function which
returns a function with a variable argument list:

void (*(myFct(const char* name, int line)))(const char* format, ...);

but there seems to be some complex interactions involved

I'm running gcc3 3.0.4 on RedHat Linux 7.2

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Clip source file from attachment and save
2. g++3 -c -x c++ -fPIC -O3 -o foo.o <source file>
3.
	

Actual Results:  "Internal compiler error" message detailed above

Expected Results:  Compiler should have given me a ton of error messages, most 
likely :-(

Additional info:

Comment 1 Dean Bandes 2002-12-11 16:54:06 UTC
Created attachment 88424 [details]
problem description, command line, and preprocesser output

Comment 2 Alan Cox 2002-12-16 02:26:12 UTC
Works ok with g++ 3.2 in 8.0



Note You need to log in before you can comment on or make changes to this bug.