Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 79417 - sshd fails in mmap() with old kernels
Summary: sshd fails in mmap() with old kernels
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh
Version: 8.0
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-11 15:47 UTC by mikpe
Modified: 2007-04-18 16:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-02-04 10:45:56 UTC


Attachments (Terms of Use)
hard-coded MAP_ANON assumption in openssh (deleted)
2002-12-11 22:07 UTC, mikpe
no flags Details

Description mikpe 2002-12-11 15:47:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
The machine has a RH8.0 installation, but since it's
used for driver development, it boots various custom
2.2/2.4/2.5 kernels.

If I boot the 2.2.23 kernel (compiled with gcc-2.95.3), then
sshd (openssh-server-3.4p1-2) rejects connections and prints

sshd[pid]: Server listening on 0.0.0.0 port 22
sshd[pid]: fatal: mmap(65536): Invalid argument

in /var/log/secure.

This problem did not occur when the machine ran RH7.x.
This problem does not occur with recent 2.4/2.5 kernels.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot RH8.0 with a 2.2.23 kernel.
2. ssh to the machine from the outside.
3.
	

Actual Results:  The ssh connection is closed immediately.


Expected Results:  The ssh connection should have succeeded.


Additional info:

Comment 1 Michael Lee Yohe 2002-12-11 19:42:26 UTC
This is NOTABUG.

Reason is this - Red Hat Linux 8.0 contains packages that are targeted
specifically for the release of the kernel that is provided by Red Hat.  If you
revert to an older kernel, you cannot necessarily to expect everything to work
because you have eliminated a "known" in the system.

It is up to you, as the user, to recompile/install supplementary packages to
your system (openssh) if you change a "known" about the system.

Comment 2 mikpe 2002-12-11 22:07:48 UTC
Created attachment 88485 [details]
hard-coded MAP_ANON assumption in openssh

Comment 3 Tomas Mraz 2005-02-04 10:45:56 UTC
See comment #1.



Note You need to log in before you can comment on or make changes to this bug.